PDA

View Full Version : atmel maXTouch, ChromeOS, and SD Card Booting... Oh My!



starrysky012
July 11th, 2018, 12:40 AM
So I did it, I successfully swapped over from Antergos Arch Linux back to the tried and true Ubuntu
I should take the time to mention that I have been a loyal ubuntu user for close to 3 years, using GalliumOS for the entirety of my school career, dual booted alongside the POS ChromeOS
However, I thought that GalliumOS lacked something --- correct sound and microphone support

For that reason, I have gone and installed Xubuntu onto a 32 GB Micro SD card, as house rules state that I cannot COMPLETELY take over the SSD of the Chromebook in case I need a chromebook for a school test or something.

So I installed, and it performs about the same as I expected. Slow, sluggish, and a PIA to use everyday. This, and the built in atmel maXTouch touchpad and keyboard dont work. I tried Libinput and Synaptics to no avail.

I have decided to cut the hard drive, and at the time of this post it will have been done successfully, with 10 GB available for the Xubuntu partition, and 6 available for ChromeOS.

However, I still will need to use the GalliumOS kernel, as it contains the correct drivers and hardware support for my hardware
How would I do this? I probably need to build the kernel. Help!


SPECS - Samsung Chromebook 3, 2GB RAM, 16GB SSD, 1.6GHz Celeron Dual Core
Xubuntu 18.04 Bionic BeaverMicro Center
Generic 32 GB Micro SD Card (Boot)
32 GB SanDisk Cruzer EXTREME (installation medium)