View Full Version : 18.04 only works in recovery mode

May 9th, 2018, 12:52 PM
I upgraded from 17.10 to 18.04 following the prompts and instructions from Software Updater. Everything went smoothly. I could see the background image had changed form the Aadvark to the Beaver, and got the "restart" message. When I hit restart, the familiar Ubuntu purple background and white / red dots appeared but then, instead of opening the OS, I got a page with lots of scrolling text, and eventually it froze. tried rebooting several times: same result. So I went for recovery mode, and it opened ok, but it žs obviously only recovery mode and I can't get the real thing to work. Any ideas? Thanks!

May 9th, 2018, 12:59 PM
After a dist-upgrade, it is usually a good idea to clean the system via 'gtkorphan' & 'bleachbit' (as root, carefully select options). Then check 'journalctl -b' to find warnings & errors. An other possible source of trouble is your own 'profile', to test create an other user, and login with him.

May 9th, 2018, 02:10 PM
Thank you

As I am unable to boot in normal mode, should I attempt your suggestions in -recovery mode? I can't login with another user if it dosn't even take me to the option of logging in, do you see what I mean?

May 9th, 2018, 04:52 PM
I would try just where you are:

sudo apt update
sudo apt dist-upgrade
sudo apt install -f

and see where it goes.

The commands above should by typed in a terminal window.
You can post some of the output here if the system complains about errors.