View Full Version : [SOLVED] 18.04 GRUB installation failed

May 2nd, 2018, 09:54 PM
Hi all,

I've recently downloaded Ubuntu 18.04 and successfully installed it on my desktop (around 10 years old, classic bios I'm guessing). My problem begins when I try to install it on my wife's laptop (HP-Pavilion dv7). She currently has 16.04 LTS installed, and when I try to upgrade using a burnt DVD following exactly the same steps as I did on my desktop I get a Grub error. Attached is the image of the error message.


I believe it might be an issue with UEFI, but this is where my knowledge ends on the matter, I've tried troubleshooting online with no luck. I don't remember having this problem when installing 16.04 on her laptop, this is what surprises me. At the moment my old GRUB is corrupted by attempting this new installation. I would love a solution around this problem to be able to get 18.04 installed on her laptop.

Any help is appreciated, for further info on the matter please request.

Thanks in advance,


May 2nd, 2018, 11:18 PM
May be best to see details, you can run from your Ubuntu live installer or any working install, use ppa version not older Boot-Repair ISO:
Post the link to the Create BootInfo summary report. Is part of Boot-Repair:
https://help.ubuntu.com/community/Boot-Info and:

See this:

Upgrading via the installer (Ubiquity) is deemed not safe due to bugs in apt-clone and so is no longer supported. (1756862) UIFE - remove ubiquity upgrade option.

May 2nd, 2018, 11:43 PM
How old is the laptop and did you check to see if it was UEFI capable? Getting boot repair and running it will give the best and most detailed information to get help. Did you read the Ubuntu documentation on UEFI at the link below?


May 3rd, 2018, 08:14 PM
Hi guys,

Thanks for your answers. So I tried doing the following:

https://help.ubuntu.com/community/Boot-Info and:

and at least that got my grub working, but I now have the problem that only Ubuntu appears on the list and I also have win10 installed next to it.

Further suggestions are appreciated.

Below I have pasted the results of Boot-Info to see if we can sort this out:


Many thanks once again,


May 3rd, 2018, 08:30 PM
Grub only boots working Windows.
And that is Windows that does not need chkdsk, nor is hibernated.
And Windows 8 or 10 uses fast start up which is just hibernation.

With BIOS install, the only way to turn off fast start is to temporarily reinstall a Windows or Windows type boot loader to MBR, turn off fast start up, and restore grub boot loader to MBR.
Best to also have Windows repair flash drive in case it needs chkdsk.
And Windows with updates will turn fast start up back on, so keep both Ubuntu live installer & Windows repair flash drive handy.

Fast Start up off (always on hibernation)

Windows 10 repair disk
How to: Create a Recovery Drive for reinstalling Windows 10 from Windows 10


May 3rd, 2018, 09:31 PM
Hi Oldfred,

Thanks for the quick answer. Before I dive into your last suggestions could you please clarify something for me. Before attempting to install 18.04 the laptop was quite happily running 16.04 alongside Win10 with no grub issues whatsoever, it was after attempting to install 18.04 that, once all the OS was installed and finishing with the installation of grub it would at that point crash and corrupt the already functioning grub. Is there any reason why 16.04 did not suffer from this but 18.04 does?

Many thanks once again,


May 3rd, 2018, 10:09 PM
Your Boot-Repair Report showed Windows was hibernated. Or Fast Start up.
And Windows updates turn that back on.

So probably coincidence that Windows update locked the NTFS partition and then grub update fails as it cannot parse the NTFS partition.

May 17th, 2018, 08:03 AM
This bug has three workarounds:
- Use a GPT partition table on the disk
- Boot the installer in legacy mode
- When both are not an option, use the workaround described in:

It's a real bug in the Ubuntu installer and should be fixed asap, it affects a lot of people.

I hope this helps, regards,

May 17th, 2018, 04:33 PM
Boot mode UEFI or BIOS needs to match partition type.
UEFI uses gpt as standard partitioning, and old systems had MBR(msdos) for BIOS.

With Ubuntu you can also install in BIOS boot mode to newer gpt partitioned drives if you have a bios_grub partition 1 or 2MB unformatted with bios_grub flag.
And if installing in UEFI boot mode (should be gpt), you must have the ESP - efi system partition - FAT32 with boot flag.

Windows only boots in UEFI mode from gpt partitioned drives and all new systems since Windows 8 (Oct 2012) must be UEFI.
Windows only boots in BIOS boot mode from MBR(msdos) partitioned drive.
Almost all Windows 7 systems were BIOS on MBR, so if system is a Windows 10 update from Windows 7, it will still be MBR and BIOS boot.

June 7th, 2018, 06:30 PM
Hi again guys,

Thanks for all the answeres, I've been absent some time but must still repair the boot system. What you talk about I can understand but my IT skills are below par to actually analize the situation and act upon it. What I really need is a walkthrough that someone might have set up on how to deal with the problem. At least I have been able to get grub to give me access to a partially corrupted Ubuntu startup page and I can then log into Ubuntu.

June 19th, 2018, 04:48 PM
Hi again,

Well, after searching for what the problem really was, I think what had happened was that Win 7 was installed as Legacy and Ubuntu as UEFI. Even so, after trying to install Win7 and Ubuntu in UEFI I still had the same problems.

From what I've read on Win forums, Win 7 doesn't fully operate as UEFI, it seems that Win OS that fully operate as UEFI are Win 8 onwards, so in the end I've had to install both as Legacy.

Many thanks for your help


June 19th, 2018, 06:00 PM
Windows 7 can be installed in UEFI boot mode, but not with UEFI Secure Boot on.
And DVD has to be copied to flash drive and files moved around/renamed to make it UEFI bootable.


On the USB flash drive, "copy" the efi\microsoft\boot folder up one level into the efi folder as efi\boot. (see screenshot below)

August 6th, 2018, 01:11 AM
I had a clean GPT partition from 16.04 with no UEFI partition or MSDOS partition like that. Upgrading from 16.04 to 18.04 I got an error about installing GRUB and on reboot, blank screen with blinking cursor.

I followed other instructions for installing GRUB, but kept getting the same error about "embedding not possible on GPT partition. blocklist required, but blocklists are not reliable, cannot continue". After trying to install from chroot environment on USB rescue image finally gave up and formatted a small disk with msdos label and ext4. Did grub-install to that disk from inside chroot and selected that disk from BIOS boot menu on reboot.

Once back into my installation, grub-install again failed with GPT error about embedding. I tried again with grub-install /dev/nvme0n1 --force and this time grub install completed and I was able to boot first try.

Might be handy to keep a rescue boot config laying around on a flash drive in case GRUB gets borked again during LTS upgrade.


August 6th, 2018, 04:28 AM
I think you forced the blocklist install which is not recommended.

With gpt, you need either an ESP - efi system partition for UEFI installs. Or a bios_grub partition so the BIOS version of grub can correctly install.

I put both of these on all new gpt partitioned drives. And have only used gpt since about 2010 when I only had BIOS and needed bios_grub. But then when Windows went to UEFI/gpt, I started adding the ESP, even though not yet using UEFI.

First two partitions. I use a smaller ESP on my flash drives with full installs.
Only if gpt - all partitions in gpt are primary (no logicals):
gpt: 300-500 MB efi FAT32 w/boot flag (ESP for UEFI boot or future use for UEFI, you only can have one per drive, so if already existing do not attempt another)
gpt: 1 or 2 MB No Format w/bios_grub flag (for BIOS boot not required for UEFI)

November 17th, 2018, 07:51 AM
I have same issue, after a lot of trouble and lost until important date including Windows 7 I discovery that the iso image from Ubuntu 18.04 only enable creation of Usb bootable in UEFI bios. I try many different applications to create a bootable image. I have Windows 7 in 32 bits and all my partitions were created a very time ago and all are in older scheme, not in gpt to use UEFI bios.
I don't know way the new LTS version only gives the archive to be downloaded which doens't works for those with Bios in MBR . Ubuntu 18.10 works for who still uses non gpt partitions with bios mbr scheme although it is not a Lts version. Well, bad new, I try install again Ubuntu 18.10 after a crash in my entire system, including lost of Windows 7 installation and after create a new USB pen-drive bootable with Rufus and also by Universal-USB-Installer-, the Live USB only create a UEFI scheme. I don't know what to do anymore (I had deleted my first 18.10 USB bootable in an attempting to install Ubuntu 18.04).
Any ideas?