PDA

View Full Version : Upgrade Lubuntu to 18.04, eclipse breaks



mrwhoohoo
May 2nd, 2018, 09:41 PM
Was previously at 16.04. Upgraded to 18.0.4.

When I start Eclipse, it responds :
An error has occurred. See the log file /home/username/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1525293593597.log

Log file reports:

!SESSION Wed May 02 21:10:36 BST 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-05-02 21:10:36.845
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.base/java.net.URLClassLoader.findClass(URLClassLoader.j ava:466)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:5 66)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:4 99)
at org.eclipse.equinox.launcher.Main.invokeFramework( Main.java:626)
at org.eclipse.equinox.launcher.Main.basicRun(Main.ja va:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:14 38)
at org.eclipse.equinox.launcher.Main.main(Main.java:1 414)

Any ideas how to fix this.

I'm a newbie with Ubuntu.

Thanks

Steve

thiago.n.costa.86
June 3rd, 2018, 12:51 AM
I'm having the same problem. Did anyone fix this?