View Full Version : [ubuntu] 18.04 Install Issue - "ubi-partman failed with exit code 10"

April 30th, 2018, 06:35 PM
Today I tried to install Ubuntu 18.04 on my Dell Inspiron 7000, which already has 17.10, but I got an error saying:
"ubi-partman failed with exit code 10.", I got three options: quit, continue anyway (not working, breaks everything) and try again (gives the same error again).
Is important to mention that I tried the minimal install and this comes after pressing the install button.

Edit: Just tried the normal version (not minimal) and selected to erase disk and install 18.04 (step not reached with minimal) but after clicking to install got a black screen with a lot of errors.

May 1st, 2018, 04:40 AM
This generally happens when the installer attempts to incorporate RAID disks in the partition scheme.

You can pre-partition the disk prior to install with something like Gparted Live:

Or you can try selecting the nodmraid option during install:

​http://i.imgur.com/6gHKCxOl.png (https://imgur.com/6gHKCxO)

May 1st, 2018, 05:12 AM
Post these:
sudo parted -l
sudo gdisk -l /dev/sda