View Full Version : [ubuntu] "Unable to fetch some archives" problem

April 30th, 2018, 06:21 PM
Hey everyone!
Let me lay out my situation here and give all the background info.
I'm doing mathematics work at my university, and I've been given the ability to login to a high-powered computation computer to do some long calculations. I log into the machine using ssh and its local address on the university's network.
I attempted to install sagemath on the computer, as I need it for some of the calculations I'm doing, but after adding the repository and, and doing

$ sudo apt-get update
$ sudo apt-get install sage-upstream-binary

the installation began, then failed with the following error:

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Of course, I had already run update, but I tried --fix-missing, and unfortunately that did not solve the problem.
I then tried

$ sudo apt-get update
$ sudo apt-get upgrade
and it failed with an identical error to when I tried to install sage.
Next I tried

$ sudo apt dist-upgrade
and, you guessed it, the same error as the last two.
It seems that all upgrade/install related commands are ending with this error. I've been given permission by the computer's owner (who doesn't know much about linux) to do what I need to to try and fix it, but I'm a little lost. Any suggestions?
Thanks! And please let me know if more info is required.

Edit: just realized I should probably add system info, huh?
The computer is running Ubuntu 15.04

April 30th, 2018, 06:28 PM
what's the actual output from those commands?

April 30th, 2018, 06:36 PM
Here it is for upgrade. It's pretty similar for the others.

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
liboxideqt-qmlplugin liboxideqtcore0 liboxideqtquick0 linux-generic
linux-headers-generic linux-image-generic oxideqt-codecs
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 786 kB of archives.
After this operation, 31.7 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
WARNING: The following packages cannot be authenticated!
Install these packages without verification? [y/N] y
Err http://us.archive.ubuntu.com/ubuntu/ vivid-updates/main linux-libc-dev amd64 3.19.0-84.92
404 Not Found [IP: 80]
Err http://security.ubuntu.com/ubuntu/ vivid-security/main linux-libc-dev amd64 3.19.0-84.92
404 Not Found [IP: 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.19.0-84.92_amd64.deb 404 Not Found [IP: 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

April 30th, 2018, 07:00 PM
That's EOL (http://fridge.ubuntu.com/2016/01/14/ubuntu-15-04-vivid-vervet-reaches-end-of-life-on-february-4-2016/) and the archives no longer exist as they are.
Install a fresh version of a supported release.
(Either 14.04 16.04 17.10 or 18.04)

Sorry to be harsh.

April 30th, 2018, 07:40 PM
Haha don't worry, I'm not offended! It's not my computer anyway.
Do you know the best way to go about the instillation?
do-release-upgrade gives

Can not upgrade

An upgrade from 'vivid' to 'xenial' is not supported with this tool.
I'd really like to avoid a fresh instillation, because at the moment I only have ssh access, but if I have to recommend that they do that I certainly will. I guess I'm just wondering if there's any way to avoid it.

April 30th, 2018, 07:52 PM
If not fresh then best option might be an EOL upgrade
But I'm not sure if it'll point to 16.04 or 15.10.

It's just miles easier to deal with by doing a clean install.
Much more so than when dealing with end of lifer's.
As an upgrade from an end of life release may have an issue or two which cannot be resolved.

April 30th, 2018, 07:57 PM
Thank you so much! That's all very helpful. Fresh install seems like it might be the way to go.