View Full Version : [ubuntu] Installing on Acer Aspire Switch 11

April 30th, 2018, 02:45 PM
I am trying to install Ubuntu on my Acer Aspire Switch 11 which came with Windows 8.1 pre-installed.
It has one USB port, no DVD/cd drive, so I am using an external drive on the USB port.
There is 18.2GB of HDD free space.I have disabled fast start up and changed the boot order in UEFI to use USB CDROM.
Secure boot is disabled. In security options , FTPM is disabled.
On start up I get the options of Windows or Ubuntu. Trying to boot Ubuntu gives the message "Windows failed to start because a file is missing, missing file is : \ubuntu\winboot\wubildr.mbr staus 0x000000f."
The CDROM starts but does not load Ubuntu.
I have tried a genuine Ubuntu DVD, genuine Ubuntu flash drive and a downloaded ISO from Canonical.
Files on the disc show WUBI is there and there is an option to use a CD boot helper which I have used, but still no luck.

Regards Steve

April 30th, 2018, 04:10 PM
Wubi does not work with gpt or then with UEFI.
Last supported version of wubi was 12.04.
Forums Staff recommendations on WUBI
But unoffical version here by hakuna_matata:

Acer often requires UEFI update & "trust" settings for UEFI install.

Acer Very latest UEFI/BIOS works, downgrade not required:

Acer Trust Settings - details, some now report that then secure boot has to be on to set trust:


April 30th, 2018, 04:38 PM
Thanks to those who replied. It seems that I am unable to install Ubuntu in the way I was trying, so how do I go about installing Ubuntu on my machine, or am I stuck with Windows 8.1?

April 30th, 2018, 04:48 PM
Do not know how similar these are.
Acer Swift 3

Acer Spin 5 Ubuntu 17.04 Needs Acer password & trust
Acer Cloudbook shows screen for selecting trust