PDA

View Full Version : [SOLVED] 16.04 hangs at who are you screen during install on windows PC



JimLS
April 8th, 2018, 09:21 PM
Had an install with Win7, Win10 and Ubuntu (think it was 14.04). Drive crashed so doing fresh install on new drive. Previous install order was Win7, ubuntu, Win10 IIRC. Motherboard is Asrock IIZ87-14B with UEFI. I got Win7 installed in one partition first. Then shrunk the partitions and made one for Win10 and Ubuntu with windows partition tool but had to resort to partition wizard to reduce the size more. That all works. When installing 16.04 I select other and select EXT4 for partition for boot point (/) and have swap partition set up. It hangs at who are you screen without giving me a continue button (remains greyed out). It's been several years since I did the original install but I don't remember having trouble with this.

JimLS
April 9th, 2018, 02:29 PM
Both disks are MBR. UEFI has compatibility turned on. I have tried with network connected, with it disconnected. Putting the boot loader on one drive and then tried the other. Sometimes it gets as far as marking the partition as Ubuntu 16.04 but it never gets to making the button pressable or getting beyond that screen or giving a selection at boot - still just boots to selection of the two windows versions. The live CD boots fine. Several years ago I was able to install 14.04 on this machine without a problem. I am out of ideas - what should I be looking at?

yancek
April 9th, 2018, 03:01 PM
Windows 7 by default was Legacy/MBR, windows 10 is UEFI/GPT. The first thing we would need to know is which it is. You would have to install Ubuntu Legacy if your windows are Legacy, UEFI if windows UEFI. Booting the Ubuntu media with the Try Ubuntu option, get to the Desktop and open a terminal and run: sudo parted -l (that should give the information on EFI/Legacy). You would need to have windows 7 and 10 the same also or you will have problems so which way did you install windows?

What is the current status? Can you boot 7? 10?, both/either? If you can boot 7 and/or 10, are either hibernated? Need that off. Use the manual install option, Something Else if it is still used.

I would not create any partition for Ubuntu from windows, just leave unallocated space.

oldfred
April 9th, 2018, 03:11 PM
If MBR(msdos), then have you used all 4 primary partitions?

From live installer in live mode, post this:
sudo parted -l

Windows 7 can be installed in UEFI boot mode, but must be copied to flash drive and some files moved/renamed to make it UEFI bootable.
How you boot install media UEFI or BIOS is then how it installs, both Windows & Ubuntu.
And all systems really need to be in same boot mode, all UEFI or all the now 35 year old BIOS/MBR configuration.

JimLS
April 9th, 2018, 03:17 PM
I can boot win7 and win10. I tried creating the partitions for Ubuntu with windows and then, thinking that could be a problem, used gparted to delete them and recreate them. Neither way worked. I will post the results of the suggested tests tonight when I am back at the machine.

JimLS
April 9th, 2018, 11:47 PM
ubuntu@ubuntu:~$ sudo parted -l
Model: ATA WDC WD20EZRZ-00Z (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 1049GB 1049GB primary fat32 boot
2 1049GB 2000GB 952GB primary fat32


Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 106MB 105MB primary ntfs boot
2 106MB 129GB 129GB primary ntfs
3 129GB 258GB 129GB primary ntfs
4 258GB 394GB 136GB extended
6 258GB 384GB 126GB logical ext4
5 384GB 394GB 10.5GB logical linux-swap(v1)


Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Model: TSSTcorp CDDVDW SH-224DB (scsi)
Disk /dev/sr0: 1624MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number Start End Size File system Name Flags
1 2048B 6143B 4096B Apple
2 1607MB 1609MB 2425kB EFI


ubuntu@ubuntu:~$

JimLS
April 10th, 2018, 12:52 AM
Operator error! I wasn't putting in a password and just checking log in automatically. Once I put in a password it installed fine. doh!