View Full Version : [SOLVED] grub won't come up when I restart after installing.

January 20th, 2018, 01:06 AM
I just installed 16.04.03 and when I restart it boots directly into windows 8.1

Standard defaults for install.
Installed a second time, same problem.
Ran powercfg /h off in windows.

From the USB try ubuntu stick:
Ran boot-repair http://paste.ubuntu.com/26419590/
It says:
=> No boot loader is installed in the MBR of /dev/sda.
=> Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sdb.

Still doesn't work. What do you suggest?

January 20th, 2018, 02:39 AM
I had gotten a message about turning off secure boot, and had tried that, but my bios won't let me.
I then hit continue and boot-repair seemed to work, but nothing happened.
I found out I have to set a bios password to disable secure boot, so I did that and reran boot-repair.

No msg this time paste.ubuntu.com/26420047
but it did not work. Still says no boot loaded installed in MBR.

Anymore Ideas -Mark

January 20th, 2018, 02:42 AM
https://paste.ubuntu.com/26420047/ (here is the link from the previous reply)
ran bcdedit in windows and it says one bootmgr and one bootloader.
no path with EFI in it.

January 20th, 2018, 03:02 AM
I tried to do a bcdedit path before but got an error.
I just tried again after disabling secure boot, then running boot-repair, and bcdedit worked.
But windows 8.1 on a ACER still boots automatically.
I've tried to have boot order of Windows boot mgr first, and HDD first.

All well, I'll keep trying. Should doing an default install be this hard?


January 20th, 2018, 04:39 PM
You have an Acer.

Acer has a unique requirement of setting "trust" on the Ubuntu/grub .efi boot files from within UEFI.
Actually better than some other brands that require major work arounds.
Also make sure you have newest UEFI from Acer. Some older threads may mention downgrading UEFI, but newer ones say upgrade works.

Acer Trust Settings - details, some now report that then secure boot has to be on to set trust:
Acer Cloudbook shows screen for selecting trust
InsydeH20 setup utility
Acer Very latest UEFI/BIOS works, downgrade not required:

January 20th, 2018, 11:03 PM
Well I removed the password from the bios, reinstalled, ran boot-repair and bcdedit.
Still not working.

January 20th, 2018, 11:34 PM
It is set password and enable trust as other threads report with more details.

January 20th, 2018, 11:45 PM
Thanks Oldfred!


did the trick. Clear step by step. Just a lot of bios work. No need to reflash.

Thanks again!