View Full Version : Ubuntu freezes at login - BIOS won't save Changes - Won't boot from USB

January 17th, 2018, 09:48 PM
Hello, I've tried to install ubuntu 17.10 on a laptop but I'm ecountering some serious issues.
My laptop is an Acer Aspire E 15 START with a Intel Celeron Processor N2840 and Intel HD graphics.
Ubuntu boots but everything freezes at login (when it gets to the desktop) and there's also a second more serious issue: bios settings don't save anymore and I can't boot from USB making it impossible to install another OS on this laptop. I can't login even in recovery mode.
Can anybody help me with these issues?
Thank you!

January 18th, 2018, 12:23 AM
You've been bitten by a nasty kernel bug:


The original 17.10 images were pulled a couple of weeks ago, but that's no help to you now :(

There are work-arounds but I think they all require that the installed OS be bootable. You might try booting with the nomodeset boot parameter and see if that gets you to usable desktop.

January 18th, 2018, 01:13 AM
I've managed to install windows by changing the hard disk, now I have a working os, but bios is still not saving settings. Can I fix this from windows?

January 18th, 2018, 01:58 AM
I would contact Acer support. If they provide a .exe BIOS download you may be able to update/fix the BIOS from within Windows, but that is just a guess!

January 18th, 2018, 02:12 AM
Already tried that, but it didn't work unfortunately

January 18th, 2018, 10:11 PM
Mostly just a free bump. The only thing I'd know of is trying to get the hard drive with Ubuntu 17.10 to boot to a usable DE and then following the repair steps in that bug report.