View Full Version : [SOLVED] Cannot install updates on Ubuntu 17.04

November 7th, 2017, 05:21 AM
When I go to Ubuntu Software | Updates and try to run updates by clicking Install button, at fist nothing happens and then I got the following error message:

E: The package linux-image-extra-4.10.0-38-generic needs to be reinstalled, but I can't find an archive for it.

It started happening after attempt to upgrade from 17.04 to 17.10. If I try to reinstall the package by running apt install --reinstall, I get the same error.

The same error if I run update-manager in the terminal.

November 7th, 2017, 09:49 AM
May be you should try by clearing apt cache.

sudo apt-get clean

And try again.

November 7th, 2017, 05:14 PM
Try changing your download source Software & Updates, Other software

Choose a better source for your location

November 14th, 2017, 04:25 AM
Thanks for the replies. I was able to solve this by running:

sudo dpkg --remove --force-remove-reinstreq linux-image-extra-4.10.0-38-generic

November 14th, 2017, 04:57 AM
How to mark threads [SOLVED] or [UNSOLVED] (https://wiki.ubuntu.com/UnansweredPostsTeam/SolvedThreads)