View Full Version : [kde] Trouble executing qbus commands that only work under specific circumstances

October 27th, 2017, 08:43 PM
I'm on Ubuntu Server 16.04.3 with kubuntu installed. Using KDE's System Settings Autostart section, I run a number of bash scripts at logon.

My original script [1] which used to work on KDE Neon Git DevStable, returns apparently unrecoverable errors [2] between starting amarok & the first qdbus command. Somehow the commands that fail in the script run fine when pasted into a terminal alone one after the other. This lead me to spend some time on paths, which ended up being a useless effort.

To achieve the desired result I've had to split the necessary commands into 2 separate bash scripts, the first of which [3] calls the second [4], which sleeps a bit so that it executes in order.

I spent far more time tinkering with this than I like to admit. Tried most everything Google threw at me, provided I didn't need to know python or whatever else was going on when others encountered something similar. I would like to learn where I went wrong, however for now I'm happy it works, regardless of it being a less than ideal solution.

Maybe it's obvious to someone here & I could be enlightened...

http://sebsauvage.net/paste/?b4249c72144e2bd3#iuJWCmzP+UD57U2SbA+3Dr12tWiMloqc Qgs73taJD3Q=

http://sebsauvage.net/paste/?4fdc69591197b9cd#Lw3DbxX0gs51Fs1QhSYXeUBp0Dct8xAx EkkWBL+H4wo=

http://sebsauvage.net/paste/?577b6456af61cc36#G0koVPDCvZiMOgSDiw+RbQMpAZd5wXpJ 5UxodNYMyRQ=


November 5th, 2017, 10:43 PM

December 2nd, 2017, 05:53 AM