PDA

View Full Version : [ubuntu] upgrade 17.04 to 17.10 boot stuck at "Started gnome display manager.....



wern1
October 20th, 2017, 11:09 PM
I upgrade from 17.04 to 17.10 but boot is stuck at

(ok) Started GNOME Display manager. script.neration........ance-master).p link was shut down....


Any help would be appreciated

eneiluj
October 21st, 2017, 07:56 PM
Same for me.

[ OK ] Started OpenVPN service. Script Dispatcher Service...ystem changes.pp link was shut down.

There seems to be disk activity. Is it possible system is doing a filesystem check ?

rajatkn
October 22nd, 2017, 07:55 AM
Same problem here..
Can't start either gdm3 or lightdm.
Also tried reinstalling & configuring both.

igouy
October 23rd, 2017, 02:02 AM
You'll need to investigate the problem further.

One of the boot options will probably be:

Advanced options for Ubuntu

:choose that, then choose:

Ubuntu, with Linux 4.13.0-16-generic (recovery mode)

:and see if you can find any error messages in the logs in failsafe graphics mode.


So far I've managed to find a problem with missing NVidia packages, which led me to a networking problem seemingly caused by some resolvconf name-server mis-configuration.

I've managed to fix the resolvconf problem enough to load the missing Nvidia packages -- but now I'm stuck at:

[ OK ] Started GNOME Display Manager.
[ OK ] Started Hostname Service.

igouy
October 23rd, 2017, 10:09 PM
fyi I'm about ready to accept that my 17.04 to 17.10 upgrade was a failure, and re-install 17.10 clean and then start doing all the other rework that will be needed. Good luck.

wern1
October 26th, 2017, 09:24 AM
Well, I got it somehow running again, but admit is was playing around without really knowing what I was doing. This just a a warning.
What I did was delete Nvidia "apt-get purge nvidia-*". I don't have an Nvidia-card but a Radeon card, so I have unfortunately no clue if this was/could be a reason. I just notice that other people also have problems upgrading from 17.04 to 17.10.
Now I have the following choices at login:

gnomegnome unter xorg
gnome under xorg (without ubuntu picture)
ubuntu (standard)
ubuntu on xorg (without ubuntu picture)
ubuntu on xorg
unity (without ubuntu picture)
All first 5 choices do NOT work, but after a loop end up again at the login screen.
Choice No 6 "Unity" works and I have my system back up running. I will for the time being not fiddle around anymore but if upgrades do not solve the problem soon, then I will at some point do a new install of 17.10.

dino99
October 26th, 2017, 09:42 AM
Please do a separate partition install for each DE, dont mix them if you lokk at stability.

wern1
October 26th, 2017, 10:18 AM
Thanks. Ehhm. Actually I would prefer only having one DE - Ubuntu 17.10 with Wayland. I don't even know how I ended up with all the choices. I was able to delete "plasma" but don't dare to fiddle around with the rest for fear of loosing access again as my competence doing this is limited.

mrgs
October 26th, 2017, 03:59 PM
There have been some reports of problems running Ubuntu 17.10 with Nvidia. I don't know the details more than 'somehow related to Wayland'.

If everything else fails you could try a fresh install of Lubuntu 17.10 which has not yet implemented Wayland.