View Full Version : [ubuntu] Boot Repair Tool stuck in scanning systems step

October 20th, 2017, 07:29 PM
after I installed ubuntu 17.10 and changed some partitions, I got the grub rescue issue and I`m trying to fix with the boot repair disk, I saw the error: Im stuck in **scanning systems (os-prober)...** for more than an our
any idea?

Ive also tried usinb a USB bootable with ubuntu 17.10 and installed boot-repair tool in terminal but I`ve got the same error no matter what I try

bootinfo: http://paste.ubuntu.com/25780936/
please tell me if you see any mistake in my partition scheme

October 20th, 2017, 08:48 PM
Better to use link Boot-Repair creates.
And if longer text output, use code tags. Code tags are easy to add in forum's advanced editor and # icon.

You have UEFI install with gpt partitions on both drives.
But you have grub installed in the old BIOS boot mode on sdb, just do not boot in BIOS mode as that should not be how you boot.

Did you run an old copy of Boot-Repair? Best not to use its own ISO as that is now old.
You can just use ppa to add to Ubuntu live installer and have much more current data.

Rerun report using ppa and post link.
May be best to see details, you can run from your Ubuntu live installer or any working install, use ppa version not older Boot-Repair ISO:
Post the link to the Create BootInfo summary report. Is part of Boot-Repair:
https://help.ubuntu.com/community/Boot-Info and:

October 20th, 2017, 08:57 PM
Hi oldfred thanks for trying to help me,
I`m using the boot repair disk from source force link found here: https://help.ubuntu.com/community/Boot-Repair isn`t that the newest one?
I have also tried to install with apt-get in my terminal and I see the same result stuck in scanning systems... after I open boot-repair

October 20th, 2017, 09:13 PM
updated my post with the bootinfo generated by boot-repair-tool

I changed to boot legacy mode thats the only way the boot-repair-tool works and I receive the following message when I click in recommended repair button

The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.

so I think I am in a loop, if I turn back to UEFI mode the boot-repair tool does not work...

October 20th, 2017, 09:14 PM
Option1 is now an old ISO with 14.04 Lubuntu. I do not think Yann has updated it.
But the Option 2 is a ppa that you add into the Ubuntu live installer and was just updated again yesterday or day before as I got a new update in my main working install.

October 20th, 2017, 09:19 PM
could you check my last comment? I have updated that adding more information

October 20th, 2017, 09:53 PM
Not sure why you cannot boot Ubuntu in UEFI mode.
What brand/model system?

October 20th, 2017, 10:01 PM
laptop lenovo ideapad 310

October 20th, 2017, 10:08 PM
I also got lots of logs before the login screen with
nouveau xxxxxxxxxxxxxxx then NMI watchdog: BUG: soft lockup - CPU#0 stuck for 22s!
this happens when I try to boot from a live USB (not boot repair tool usb)

October 20th, 2017, 10:54 PM
ok I managed to boot from an older ubuntu version using a live USB, and boot repair tool gave me a new report:

An error occurred during the repair.

Please write on a paper the following URL:

In case you still experience boot problem, indicate this URL to:

Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].

which HD should I use to create this partition? SSD(sda) or normal HD(sdb) ?

October 21st, 2017, 03:03 AM
See if this works first.
dosfstools - dosfsck (aka fsck.msdos and fsck.vfat) utilities
Must be unmounted
sudo dosfsck -t -a -w /dev/sdXY where x is drive and Y is the ESP or FAT32 partition.
The -a seems to help in clearing dirty bit