PDA

View Full Version : need to switch from Lubuntu to Ubuntu



Dreadsen
October 7th, 2017, 11:22 PM
Hello

I had a problem with ubuntu being stuck in login loop.

I followed some instructions that had me switch to Lubuntu and from there applied some remedies that fixed the loop problem.

But now I'm stuck with lubuntu, no task bar, folder launcher, nothing. Just a plain lubuntu screen and a mouse pointer.

How do I switch back to ubuntu and get my old out of the box desktop back?

RobGoss
October 8th, 2017, 12:15 AM
How did you switch to Lubuntu from Ubuntu, did you do a clean installation?

Dreadsen
October 8th, 2017, 12:23 AM
No it wasn't a clean installation.

Same files, same hard drive encryption password.

Same log on password.

Everything stayed the same

RobGoss
October 8th, 2017, 12:33 AM
I would suggest making a complete backup of any important data and files, download what version of Ubuntu you want to install and do a clean installation to avoid problems like this. I for one do not know how to convert over from one distribution to another with out doing a clean installation.

Dreadsen
October 8th, 2017, 03:22 AM
Oh I see this is what I did.

It installed lubuntu desktop environment. But it's still ubuntu

https://askubuntu.com/questions/223501/ubuntu-gets-stuck-in-a-login-loop


Does this help explain what happened?

mrgs
October 8th, 2017, 07:17 AM
I agree with the poster above: Try a clean install of Lubuntu. It will give people here a much better foundation for helping.

Dreadsen
October 8th, 2017, 07:54 AM
It's still ubuntu this was the command

sudo apt-get -y install lubuntu-desktop

This will install a much lighter desktop environment which should work for now (should enable you to login and use your computer). Once that is done, reboot (sudo reboot), and when you are confronted with the login page, select the Lubuntu environment instead of Ubuntu."

I'm trying to understand what happened. In terminal it says it's ubuntu. But the login screen say lubuntu.

What did that command do? It didn't install lubuntu it just changed the appearance. I guess I can go find a large enough external drive to back the files up and do a clean install. But I'd still like to know what those instructions did

vanadium
October 8th, 2017, 10:42 AM
In your case, a reinstall might not be needed. Try solving the login loop issue using the instructions you linked to. You can easily do that from within your working Xubuntu session. Then log out, and when logging in, select the Ubuntu session to check whether the issue was solved successfully.

if you try to understand what happened: a login loop may be caused by wrong permissions of a configuration file .Xauthority. This can happen if you incorrectly run graphical programs as root. Next time, you can't graphically log in anymore because of that.
Wat you did was to install the lubuntu desktop. This installs the lubuntu desktop next to your regular Ubuntu desktop. At login time, you can select (clicking the cog icon) what session you can use. In your case, you will have an Ubuntu and a Lubuntu session.

Dreadsen
October 9th, 2017, 03:03 AM
In your case, a reinstall might not be needed. Try solving the login loop issue using the instructions you linked to. You can easily do that from within your working Xubuntu session. Then log out, and when logging in, select the Ubuntu session to check whether the issue was solved successfully.

if you try to understand what happened: a login loop may be caused by wrong permissions of a configuration file .Xauthority. This can happen if you incorrectly run graphical programs as root. Next time, you can't graphically log in anymore because of that.
Wat you did was to install the lubuntu desktop. This installs the lubuntu desktop next to your regular Ubuntu desktop. At login time, you can select (clicking the cog icon) what session you can use. In your case, you will have an Ubuntu and a Lubuntu session.

yes i do not think so. okay i no longer have the login loop. but now this where i am at. its like i have ubuntu with lubuntu at the same time. i'll post photos of what happens now when i boot up. i get the burgundy screen from ubuntu but then it goes to these lubuntu .

but if i hit ctrl , alt f3 you can see it is still ubuntu.

the login loop is resolved. now i want the ubuntu environment back

guber2
October 9th, 2017, 04:59 AM
When you install lubuntu-desktop you will be able to choose the Lubuntu session from the panel at the greeter.
This command tells you what desktop session you are in.

echo $DESKTOP_SESSION

Dreadsen
October 9th, 2017, 01:01 PM
When you install lubuntu-desktop you will be able to choose the Lubuntu session from the panel at the greeter.
This command tells you what desktop session you are in.

echo $DESKTOP_SESSION

Yes I just did this. Ubuntu was pre selected. Immediately after I sign in that top bar disappears.

vanadium
October 9th, 2017, 01:32 PM
Reset your unity settings to factory default. Open a terminal and issue following commands:


dconf reset -f /org/compiz/
setsid unity


To have the default login screen back, edit the



gksudo gedit /etc/lightdm/lightdm.conf


Make sure user-session and greeter-session look like:



user-session=ubuntu
greeter-session=unity-greeter

Dreadsen
October 10th, 2017, 03:04 AM
When you install lubuntu-desktop you will be able to choose the Lubuntu session from the panel at the greeter.
This command tells you what desktop session you are in.

echo $DESKTOP_SESSION

Thanks. I tried that. Ubuntu was already selected.
Th after I signed in that top menu bar disappeared.

So my session is ubuntu but it still is in that lubuntu environment

guber2
October 11th, 2017, 12:06 AM
Does "echo $DESKTOP_SESSION" show Lubuntu when you are logged into the ubuntu session.?
What happens when you log into the Lubuntu session then?
The lubuntu session has it's own default applications and panel.
277072

Did you try running vanadium's suggestion.

dconf reset -f /org/compiz/
Then logging out and into the Ubuntu session.

Dreadsen
October 11th, 2017, 07:31 PM
On the first command this is what happened

Dreadsen
October 11th, 2017, 08:36 PM
Reset your unity settings to factory default. Open a terminal and issue following commands:


dconf reset -f /org/compiz/
setsid unity


To have the default login screen back, edit the



gksudo gedit /etc/lightdm/lightdm.conf


Make sure user-session and greeter-session look like:



user-session=ubuntu
greeter-session=unity-greeter


This is what happened after I tried the 2nd command

guber2
October 12th, 2017, 12:42 AM
The commands given by vanadium are meant to be run from a graphical session not a tty terminal(ctrl+alt+F1)
If you cannot log into either the Ubuntu session or the Lubuntu session, I suggest as others have said...backup and reinstall.
When you don't fully understand what you're doing it's hard to figure out what's wrong or how to fix.

PS A tty terminal shows "Ubuntu" at the top because whether or not Lubuntu is installed the base files are still Ubuntu
and you're not logged into a graphical environment.
All the sessions selectable at the greeter use the same Ubuntu base files.
Lubuntu uses the LXDE desktop environment in place of Ubuntu's Unity graphical shell.