View Full Version : Troubles with installing Ubuntu along with Windows 10

October 7th, 2017, 08:27 PM
Hi guys, bought some time ago new laptop and today decided to install Linux Ubuntu as i used to before.
I get some troubles becasue after booting from USB getting some error's(tried already USB 2.0 and 3.0 with Rufus, Unetbootin, Universal-USB-Installer).
First screen:

After that tried with nomodeset and that also didnt help:
Any clues guys? Tomorrow I will try again with CD and maybe with anoter USB-stick. Thanks & regards.

October 7th, 2017, 08:44 PM
When using Windows, do the same USB sticks read/write normally?

October 7th, 2017, 11:47 PM
yup, everything works propertly.
just tried installing antergos. same story :/

unplugged my mouse from USB 3.0 + deleted secure boot keys from UEFI and errors about USB devices & initramfs are already gone but there are still those about kernel channel and claiming resources.
did with nomodeset - error about kernel channel gone.
there are only these left about msft0101 - any clues?
finally get rid of errors from msft0101 after disabling TPM.
however i get new errors! FTW!

October 8th, 2017, 03:31 AM
What brand/model system? Some require extra boot parameters.
UEFI install? See also info in link in my signature.

And if nVidia, you normally need nomodeset until you install and then install the nVidia proprietary drivers from the Ubuntu repository (not nVidia directly).
At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
How to add boot parameters, grub menu after install (also grub when UEFI)

October 8th, 2017, 11:58 AM
HP Omen, Win10, UEFI.
All the time was placing nomodeset before quiet splash ._. Will try your way in one moment.

That also didnt help :/
Tried also running Ubuntu in Live Mode - turned off Fast Boot and it says Windows is in hibernate mode..

October 8th, 2017, 03:20 PM
UEFI has fast boot and Windows has fast start up which is just hibernation. They are separate settings.

Fast Start up off (always on hibernation)

And Windows will regularly turn fast start up back on with some updates. And Windows updates may be in background, so you may not know for sure setting has changes.
Grub will not boot hibernated Windows nor Windows needing chkdsk. Best to make the Windows repair flash drive now before you have to have it. You may need it whether installing Linux or not.

October 9th, 2017, 05:07 PM
Ok, it went further but stuck again on "(initramfs) unable to find a medium containing a live file system" besides that I turned off already security boot and cleaned whole keys.

October 9th, 2017, 07:07 PM
Have you verified download of ISO was correct?

Have you updated UEFI from HP to latest version?

Older thread, but with updates and variety of suggested solutions.

October 9th, 2017, 08:28 PM
Downloaded ISO from offical site + checked md5 already and its correct.
Ye, got HP software and that says everything is up to date.
Unfortunely cant try installing from CD because my notebook dont have CD-ROM.
Cant find any option in UEFI to change SATA mode to AHCI.
I will try in a few moments installing it on another PC.

October 10th, 2017, 12:29 AM
What SATA modes do you have?
Sometimes settings are hidden or at a lower level.
And sometimes you have to add an UEFI password (never lose that or reset to no password after) to see additional settings.

Lenovo got into trouble for not having an AHCI setting & had to release UEFI update.

If no AHCI mode, contact HP.

October 10th, 2017, 09:22 AM
Cant find anything about SATA modes in UEFI even after setting an password.
Did some research and found that people already installed Linux on OMEN.
I guess it already works on AHCI, however I will try to prove it on first.

In device manager -> IDE ATA/ATAPI controllers found: Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller, so I guess it already working on AHCI?

"There are no BIOS settings to change the drive controller in HP consumer notebooks. Only select business notebooks have that option."

Just read that AHCI mode is needed to get SSD's working propertly, didnt know that before. Anyway i got SSD & HDD, so we can confirm at this moment it works on AHCI?

October 10th, 2017, 03:42 PM
If it came with SSD, I would expect they have AHCI implemented.

In my Asus motherboard system many lines down:

lspci -nnk
00:1f.2 SATA controller [0106]: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode] [8086:8c82]
Subsystem: ASUSTeK Computer Inc. 9 Series Chipset Family SATA Controller [AHCI Mode] [1043:8534]
Kernel driver in use: ahci
Kernel modules: ahci

October 10th, 2017, 04:48 PM
So I guess im already on AHCI mode, no other way. However, still can't get over that.

February 16th, 2018, 02:35 AM
Any luck daniel222?

February 16th, 2018, 06:06 PM
sharathpro, please start your own thread if you need help; daniel222 hasn't returned to the forum since last October.

February 17th, 2018, 05:16 AM
This looks like the grub2 was not properly installed. I recommend reading


And scrolling down to the section that has the commands:

grub> set root=(hd0,1)
grub> linux /boot/vmlinuz-3.13.0-29-generic root=/dev/sda1
grub> initrd /boot/initrd.img-3.13.0-29-generic
grub> boot

It is imperative that when you set the root on the first command that you set it where you Linux partition is. The same applies to the second line at root=/dev/sda1. So you may have your Linux partition on (hd0,8). In that case you’d type:

grub> set root=(hd0,8)
grub> linux /boot/vmlinuz-3.13.0-29-generic root=/dev/sda8
grub> initrd /boot/initrd.img-3.13.0-29-generic
grub> boot

Now like Carla Schroder says in her article, this is a temporary fix. It’ll allow you to boot into your Linux box…but you’ll have to type that in ever single time after you shutdown.