View Full Version : 17.04: frozen mouse

July 4th, 2017, 08:13 PM
I tried to install Ubuntu 17.04 today, but the installation was quite problemful. My original intention was to install Mint 18.2, but it displays the same symptoms.

First, it gets stuck somewhere on the black screen with ubuntu logo before showing the desktop environment during the installation. So I tried providing "nomodeset" kernel parameter. This solved the issue, I can boot and login. However mouse freezes after 30s or so. The OS itself is not frozen at all, it is usable with keyboard.

I suspect that this has something to do with the nomodeset + AMD CPU + GPU that I have. Could somebody please help?

My system specs are as follows:

System: Host: acer Kernel: 4.10.0-19-generic x86_64 (64 bit gcc: 6.3.0)
Desktop: Gnome (Gtk 3.22.11-0ubuntu3) Distro: Ubuntu 17.04
Machine: Device: laptop System: Acer product: Aspire E5-553G v: V1.13
Mobo: Acer model: Wasp_BR v: V1.13
UEFI: Insyde v: V1.13 date: 11/15/2016
Battery BAT1: charge: 9.5 Wh 37.6% condition: 25.4/28.0 Wh (91%)
model: SIMPLO AS16A7K status: Charging
CPU: Quad core AMD FX-9800P RADEON R7 12 COMPUTE CORES 4C+8G (-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 21560
clock speeds: max: 2700 MHz 1: 1400 MHz 2: 1800 MHz 3: 1800 MHz
4: 1400 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Carrizo bus-ID: 00:01.0
Card-2: Advanced Micro Devices [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445]
bus-ID: 07:00.0
Display Server: X.Org 1.19.3 drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
Resolution: 1920x1080@77.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
GLX Version: 3.0 Mesa 17.0.3 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD] Device 157a
driver: snd_hda_intel bus-ID: 00:09.2
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
driver: snd_hda_intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture v: k4.10.0-19-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.1
IF: enp1s0f1 state: down mac: <filter>
Card-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
driver: ath10k_pci bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 766.7GB (3.7% used)
ID-1: /dev/sda model: SanDisk_SD8SB8U5 size: 512.1GB temp: 41C
ID-2: /dev/sdb model: LITEON_CV3 size: 128.0GB temp: 0C
ID-3: USB /dev/sdc model: Silicon size: 126.6GB temp: 0C
Partition: ID-1: / size: 115G used: 4.7G (5%) fs: ext4 dev: /dev/sdb3
ID-2: /home size: 469G used: 75M (1%) fs: ext4 dev: /dev/sda1
ID-3: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 0.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 231 Uptime: 11 min Memory: 1340.4/15562.8MB
Init: systemd runlevel: 5 Gcc sys: 6.3.0
Client: Shell (bash 4.4.71) inxi: 2.3.8

August 27th, 2017, 11:04 PM
Update to my original post: the problem is linked to the kernel release. Everything else being the same, the problem surfaces if the kernel version is switched to 4.8, 4.10, 4.11. Everything is perfectly fine with 4.4, which is what I am currently using to circumvent this problem.