View Full Version : [SOLVED] Unable to install Ubuntu 16.04.2 on XPS 13-grub-install /dev/nvme0n1 failed

March 23rd, 2017, 11:29 AM
Hi, I am trying to dual boot Ubuntu 16.04.2 LTS and windows 10 on Dell XPS 13 (9350) laptop. Windows 10 came pre-installed and I am installing Ubuntu via bootable USB stick using Rufus. I have tried both the "install alongside Windows option" and manual configuration (Something else) as well, In both cases it installs more than halfway, then prompts the error:

Unable to install GRUB in /dev/nvme0n1
Executing 'grub-install /dev/nvme0n1 failed
This is a fatal error

Installation and Error Pics:


I have the following configurations set in BIOS (Version: Dell Inc. 1.4.13, 28-Dec-16):

UEFI Boot, Enable UEFI Network Stack, AHCI, Secure Boot disabled.

BIOS Config Pics:

I have also tried boot-repair


Any help would be greatly appreciated. Thank you!

March 23rd, 2017, 01:55 PM
This problem seems similar to yours, https://ubuntuforums.org/showthread.php?t=2353288

March 23rd, 2017, 02:49 PM
I have seen some with Dell that have to have the legacy boot option checked or on to work, but still install in UEFI boot mode. Most systems must have the legacy/CSM/BIOS option off to install in UEFI mode.

You should also make sure you have newest UEFI from Dell and NVMe drive's firmware.

Another user with XPS and NVMe drive.
Dell XPS 13 9360 16.04 worked after nvme firmware & BIOS update, 16.10 did not, new rEFInd for NVMe
Dell XPS 13 9360 Dualboot Windows 10 and Ubuntu 16.04 AHCI NVMe

March 24th, 2017, 11:24 AM
This solved the issue :