View Full Version : [SOLVED] 16.04 Black Screen after login.

March 13th, 2017, 11:43 PM
I have recently upgraded this amd64 machine from 14.04 LTS to 16.04 LTS with the nvidia-current drivers installed. I have a problem logging into either the Default Ubuntu environment or the Gnome (Compiz) I can log into the gnome (Metacity). Both cases the login is accepted but the screen goes black, except for the mouse pointer. I have searched for solutions and found several suggestions and tried all of them.

I have removed and reinstall the Nvidia drivers. I have removed and reinstalled the Ubuntu Desktop (which also removed and reinstalled unity). I have removed and reinstalled compiz. The greeter seems to work fine.

March 15th, 2017, 03:05 AM
I don't know if this is progress.

I installed gnome. I lot of packages seemed to be missing.
that got me a few more login options GNOME and GNOME CLASSIC which WORK.
I cant still log into METACITY.
I have purged and reinstall compiz, ubuntu-desktop and unity I still can't log into COMPIZ or the UBUNTU DEFAULT The screen goes blank and all I have is a mouse pointer. To me that points to a problem with COMPIZ.

I can still log into METACITY.

I haven't found anything in the logs pointing to a problem.
And oh yest it worked on this hardware under 14.04LTS.

March 15th, 2017, 04:39 AM
MAybe some progress. I have installed gnome. that has added two additional working logins GNOME and GNOME CLASSIC. I can still login to GNOME(Metacity)

I purged and reinstalled compiz, ubuntu-desktop and unity with no luck.

I still can't login in using the GNOME(COMPIZ) if the Ubuntu DEFAULT.
Both go black after logging in.

I've searched the forums and tried pretty much everything. I can't find any error in logs.

March 15th, 2017, 05:05 AM
Success sort of. I purged nvidia* and rebooted using the nouveau drivers, I was able to login to all session, but I've had some many problems with the nouveau driver that I'm holding my breath to see if it really works.