View Full Version : [ubuntu] Dell Inspiron 1545 - Installation issue with 14.04 LTS

March 9th, 2017, 10:12 AM

I'm stuck with Ubuntu installation on my Dell Inspiron 1545 laptop since about a week.
Version in question: 14.04
The live CD works just perfect.
However, post installation, there is no mouse, no ethernet & no wireless.
(Even the USB keyboard doesn't work but that's not really a blocker as the laptop keyboard works just fine)

Gone through several iterations of installing the same version, different minor versions (tried 16.04, 14.04.2 and currently on 14.04.4).
Behavior is the same across all attempts.

There are some solutions discussed in this & other forums for specific problems - say mouse not detected.
But with no internet & no mouse, I've really moved nowhere.

Any help would be much appreciated.
Thanks a lot.

March 10th, 2017, 06:12 AM
Since the keyboard is functional, I'm able to launch a few programs & use the terminal.
Can someone please guide to set this right?

Bucky Ball
March 10th, 2017, 07:18 AM
A) Plug in an ethernet cable if you can and you haven't already. That will help your cause and make fixing this MUCH easier.

B) 14.04.4 is EOL (end of life) and no longer supported (https://wiki.ubuntu.com/Releases). Suggest you use 14.04.5 or 16.04.2.

C) What are the specs of the machine? How much RAM and what video card specifically.

D) I've never owned a Dell but have been around here for longer than I care to remember. From what I've seen here, you need to jump through hoops to install on some of them, but as you are installed okay, you may need to add an option to the boot line specifically for the Dell model you are running. This option I wouldn't have a clue about.

Hopefully someone familiar with Dell laptops and their anomalies in regards to Ubuntu will jump in soon, but hope that's of some help. ;)

March 10th, 2017, 02:41 PM
I had a 1545. The only issue I had was with the Realtek wifi card, which I solved with a (cheap, used) intel.