View Full Version : [SOLVED] Ubuntu on Acer Spin1 (Apollo Lake)

February 20th, 2017, 08:52 PM
I have tried boot Ubuntu 16.10/17.04 on my Acer Spin1 (CPU: Apollo Lake Intel Celeron N3450/GPU: Intel HD Graphics 500/BIOS: InsydeH20 Setup Utility Rev. 5.0, Version: 1.01/RAM: 4GB/HDD: eMMC 32GB) but I had no luck with it. Originally there was Windows 10 installed but I formatted HDD with the Arch linux (the only one linux distribution which I could boot properly). What have I tried:
- disabled Secure Boot option in BIOS
- added an UEFI file as trusted for executing from the USB with installed Ubuntu in BIOS
- created bootable USB with rufus or directly from a computer with Ubuntu installed
The problem is when I try to boot the Ubuntu from USB I only see white underscore character in the upper-left corner of the screen and Acer logo in the middle of the screen. Do you have some idea about this situation? Is it something wrong with grub or do I need to wait for new kernel 4.10 in Ubuntu 17.04? Personally, I have no idea how I can boot Ubuntu on the Acer Spin1 properly and also in this situation I have no logs which I can provided for you (sorry for my English). Thank you.

February 22nd, 2017, 12:28 AM
You may need nomodeset?

Are you booting in BIOS or UEFI boot mode?
Have you installed latest UEFI from Acer?

At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
How to add boot parameters, grub menu after install (also grub when UEFI)

Other Acer models. Once installed, Acer has a unique requirement of setting an UEFI supervisory password and then from inside UEFI drill down to /EFI/ubuntu and set trust on the .efi boot files.

Acer Aspire ES1-132 cannot able to install kubuntu UEFI missing options, rEFInd
Acer Aspire R5-417T
Acer Trust Settings - details:
Acer Cloudbook shows screen for selecting trust
InsydeH20 setup utility
Acer Very latest UEFI/BIOS works, downgrade not required:

February 22nd, 2017, 05:27 PM
Thank you Sir. I did a lot of testing and it seems that BIOS v1.01 for Spin SP111-31 is buggy. I asked Acer technical support if they check the situation or provide me a newer version of BIOS. So, we will see...I will share my experiences with you.

March 2nd, 2017, 10:42 PM
So the solution is enabling "Network Boot" and "F12 Boot Menu" in BIOS.

April 1st, 2017, 07:44 PM
So the solution is enabling "Network Boot" and "F12 Boot Menu" in BIOS.

So is ubuntu working fine on Spin1?