PDA

View Full Version : "VFS: Unable to mount root fs on unknown-block(0,0)" during install



kuroyuki4
February 11th, 2017, 05:34 AM
Hi everyone!

I'm having a small issue with my Ubuntu 16.04 USB installation disk. I'm trying to install it on an older desktop (Presario SR5333WM), and I get a kernel panic every single time, before it even reaches the Ubuntu splash screen.

I've also tried using a LiveCD with the same version burnt onto it. It didn't do anything different. Both are AMD64 (the CPU is also x64), and both of them seem to work on every other computer I've tested it on so far. Would anyone happen to know what the problem could be? I've even tried wiping the hard drive, with no success.

Specs:

256 MB DDR2 SDRAM
AMD Athlon 64 X2 5200+
Seagate ST3360320AS
Nvidia GeForce 6150SE (I'm not sure about this one)

I had to replace the RAM earlier this month, because the old one failed. I only had a 256 MB stick on-hand.

DuckHook
February 11th, 2017, 08:26 AM
Welcome to the forums, kuroyuki4,

Your specs and especially the RAM are too under-powered for anything except possibly Lubuntu. It's the lightest-weight of all the 'buntus, but in all honesty, I doubt you will be happy even with Lubuntu unless you add more memory. You might wish to consider Puppy, Slitaz or Tiny Core, which are designed to run on very old or resource-limited systems.

However, lack of resources does not usually lead to kernel panics, so I would also suspect a HW issue. You mention past RAM issues . Have you checked to make sure the new RAM is okay? What about the RAM controller?

Another possibility is to forego a GUI altogether and run it as a server of some kind. Once you get rid of the GUI, your old desktop gets a new lease on life.

mrgs
February 11th, 2017, 11:08 AM
Agree with the post above: RAM is a severe limitation.

If you happen to find some more then the next problem is the 6150 graphics processor which needs special treatment. One way of dealing with it is to install Lubuntu and add closed-source drivers as soon as you get the option, that is during install and not after a reboot.

kuroyuki4
February 11th, 2017, 06:38 PM
I actually had plans to upgrade the hardware in the future. I was just testing to see if I could get any 'Buntu or other distro running on it.

The RAM I currently have installed seems to work just fine in Windows XP (the OS I have installed right now). The slot adjacent to it doesn't work though; the entire system spontaneously crashes if anything is plugged into it.

I'll definitely consider installing one of the OS's you suggested. Hopefully these will work just fine.

DuckHook
February 11th, 2017, 10:14 PM
The slot adjacent to it doesn't work though; the entire system spontaneously crashes if anything is plugged into it.This suggests a wonky RAM subsystem. Linux access RAM differently than Windows, especially an OS as ancient as XP, so it is possible your kernel panic won't be solved with any distro. However, one of the many nice things about Linux is it's free. No issues trying out as many LiveUSB distros as you like.

Let us know how it goes.

kuroyuki4
February 12th, 2017, 04:09 AM
Interesting... I was always under the impression most operating systems accessed RAM in a similar fashion.

If that's the case, I might not get any distros working on it. Still, I'll try a few out and see if I have any luck getting one to run.

DuckHook
February 12th, 2017, 05:56 AM
There will be a clear difference between 32-bit and 64-bit for example. They must use RAM differently if only because of the different address lengths. You might try a 32-bit Lubuntu to see if this makes a difference in stability.

kuroyuki4
February 14th, 2017, 11:19 PM
I just tried 32-bit Lubuntu to see if I would get better results. Nothing changed at all, unfortunately; it kernel panicked again, before it even loaded the installer.