PDA

View Full Version : 14.04 to 16.04 failed upgrade stuck with massive dependency problems



sleemanj
February 3rd, 2017, 10:21 AM
To cut a very very long arduous journey of a story short I have a failed 14.04 upgrade to 16.04 due to hardware upgrades (to an ASUS Z270M-PLUS for the future googlers).

Luckily I'm working on a duplicate, my existing live system is still alive, or I'd be really tearing my hair out by now.

Anyway do-release-upgrade looked like it was going smoothly, until it bombed out with a massive dependency hell I can't even begin to work out how to resolve.

Can anybody offer any pearls of wisdom. `apt-get -f install` (or dist-upgrade) doesn't help, nor does `dpkg --configure -a`


$ cat sources.list | grep -vP "^#"

deb http://archive.ubuntu.com/ubuntu/ xenial main universe restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu/ xenial main universe restricted multiverse #Added by software-properties
deb http://archive.ubuntu.com/ubuntu/ xenial-updates universe main multiverse restricted
deb http://archive.ubuntu.com/ubuntu/ xenial-backports universe main multiverse restricted
deb http://security.ubuntu.com/ubuntu/ xenial-security multiverse restricted universe main


$ sudo apt-get -f install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
amarok : Depends: libtag1c2a (>= 1.8) but it is not installable
amarok-utils : Depends: libtag1c2a (>= 1.6-2~) but it is not installable
appmenu-qt5 : Depends: qtbase-abi-5-2-1 but it is not installable
astrometry.net : Depends: libgsl2 but it is not installed
Recommends: libcfitsio-bin but it is not installed
Recommends: sextractor but it is not installed
baloo-kf5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
bluedevil : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
bogofilter-bdb : Depends: libgsl2 but it is not installed
breeze : Depends: kde-style-breeze (= 4:5.5.5-0ubuntu1) but it is not installed
Depends: kde-style-breeze-qt4 (= 4:5.5.5-0ubuntu1) but it is not installed
Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
calligrasheets : Depends: libgsl2 but it is not installed
clementine : Depends: libtag1c2a (>= 1.9.1) but it is not installable
compiz-core : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
cowbell : Depends: libtag1c2a (>= 1.5) but it is not installable
Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
default-jre : Depends: default-jre-headless (= 2:1.8-56ubuntu2) but 2:1.7-51 is installed
Depends: openjdk-8-jre but it is not installed
default-jre-headless : Depends: openjdk-7-jre-headless (>= 7~u3-2.1.1) but it is not installable
easytag : Depends: libtag1c2a (>= 1.9.1) but it is not installable
enblend : Depends: libgsl2 but it is not installed
enfuse : Depends: libgsl2 but it is not installed
filezilla : Depends: libtinyxml2.6.2 but it is not installable
frameworkintegration : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
frei0r-plugins : Depends: libopencv-core2.4 but it is not installable
Depends: libopencv-imgproc2.4 but it is not installable
Depends: libopencv-objdetect2.4 but it is not installable
gdm : Depends: libgdm1 (= 3.10.0.1-0ubuntu3.2) but 3.18.3-0ubuntu2 is installed
Depends: gir1.2-gdm-1.0 (= 3.10.0.1-0ubuntu3.2) but 3.18.3-0ubuntu2 is installed
gir1.2-cogl-1.0 : Depends: libcogl15 (>= 1.15.8) but it is not installable
gir1.2-freedesktop : Depends: gir1.2-glib-2.0 (= 1.40.0-1ubuntu0.2) but 1.46.0-3ubuntu1 is installed
gnome-bluetooth : Depends: gir1.2-gnomebluetooth-1.0 (= 3.8.2.1-0ubuntu4.2) but 3.18.2-1ubuntu2 is installed
Depends: obexd-client but it is not installable
gnome-rdp : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
gnome-session : Depends: gnome-session-common (= 3.9.90-0ubuntu12.1) but 3.18.1.2-1ubuntu1.16.04.2 is installed
gnome-session-flashback : Depends: gnome-session-bin (>= 3.15.3) but 3.9.90-0ubuntu12.1 is installed
gnome-system-monitor : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
gparted : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
gstreamer0.10-plugins-good : Depends: libtag1c2a (>= 1.5) but it is not installable
gstreamer1.0-clutter : Depends: libcogl15 (>= 1.15.8) but it is not installable
gvfs : Depends: gvfs-libs (= 1.20.3-0ubuntu1.2) but 1.28.2-1ubuntu1~16.04.1 is installed
gvfs:i386 : Depends: gvfs-libs:i386 (= 1.20.3-0ubuntu1.2) but 1.28.2-1ubuntu1~16.04.1 is installed
gvfs-backends : Depends: gvfs-libs (= 1.20.3-0ubuntu1.2) but 1.28.2-1ubuntu1~16.04.1 is installed
gvfs-daemons : Depends: gvfs-libs (= 1.20.3-0ubuntu1.2) but 1.28.2-1ubuntu1~16.04.1 is installed
gvfs-libs : Depends: gvfs-common (= 1.28.2-1ubuntu1~16.04.1) but 1.20.3-0ubuntu1.2 is installed
gvfs-libs:i386 : Depends: gvfs-common:i386 (= 1.28.2-1ubuntu1~16.04.1)
icedtea-6-jre-jamvm : Depends: openjdk-6-jre-headless (= 6b40-1.13.12-0ubuntu0.14.04.3) but it is not installable
icedtea-7-jre-jamvm : Depends: openjdk-7-jre-headless (= 7u121-2.6.8-1ubuntu0.14.04.1) but it is not installable
icedtea-plugin : Depends: icedtea-8-plugin but it is not installed
imms-common : Depends: libtag1c2a (>= 1.5) but it is not installable
inkscape : Depends: libatkmm-1.6-1 (>= 2.22.1) but it is not installable
Depends: libcairomm-1.0-1 (>= 1.6.4) but it is not installable
Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but it is not installable
Depends: libpangomm-1.4-1 (>= 2.27.1) but it is not installable
Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
juk : Depends: libtag1c2a (>= 1.9.1) but it is not installable
k3d : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
kaccounts-integration : Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
Recommends: kaccounts-providers but it is not installed
kactivities : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kapptemplate : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.98.0) but it is not installed
kde-cli-tools : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kde-plasma-desktop : Depends: kde-workspace (>= 4:4.11) but it is not installable
Recommends: kdm (>= 4:4.11) but it is not installable
kde-spectacle : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kde-telepathy-approver : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kde-telepathy-auth-handler : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kde-telepathy-contact-list : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kde-telepathy-filetransfer-handler : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kde-telepathy-integration-module : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kde-telepathy-kaccounts : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kde-telepathy-kpeople : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kde-telepathy-text-ui : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kded5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kdelibs-bin : Depends: libkrosscore4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
kdelibs5-dev : Depends: libkde3support4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkpty4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdesu5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkfile4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libknewstuff2-4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libknewstuff3-4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkparts4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkhtml5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkmediaplayer4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libktexteditor4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdnssd4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkrosscore4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkrossui4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdewebkit5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkidletime4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkprintutils4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdeclarative5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
kdelibs5-plugins : Depends: libkde3support4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdewebkit5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkfile4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkhtml5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkparts4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkrosscore4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
kdenlive : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
khelpcenter : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
khotkeys : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kid3-core : Depends: libtag1c2a (>= 1.9.1) but it is not installable
kinit : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
kio : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kio-extras : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kpackagetool5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
krita : Depends: libgsl2 but it is not installed
ksysguard : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.98.0) but it is not installed
ktorrent : Depends: libtag1c2a (>= 1.5) but it is not installable
kwin-common : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
kwin-style-breeze : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libalgorithm-diff-xs-perl : Depends: perlapi-5.18.1 but it is not installable
libapparmor-perl : Depends: perlapi-5.18.2 but it is not installable
libapt-pkg-perl : Depends: perlapi-5.18.1 but it is not installable
libart2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libastrometry0 : Depends: libgsl2 but it is not installed
libasync-interrupt-perl : Depends: perlapi-5.18.1 but it is not installable
libatkmm-1.6-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
libaudio-flac-header-perl : Depends: perlapi-5.18.1 but it is not installable
libbaloofiles4 : Depends: libxapian22 but it is not installable
libbaloopim4 : Depends: libxapian22 but it is not installable
libbalooxapian4 : Depends: libxapian22 but it is not installable
libcairo-perl : Depends: perlapi-5.18.1 but it is not installable
libclass-c3-xs-perl : Depends: perlapi-5.18.1 but it is not installable
libclone-perl : Depends: perlapi-5.18.1 but it is not installable
libclutter-gst-2.0-0 : Depends: libcogl15 (>= 1.15.8) but it is not installable
libcogl-pango15 : Depends: libcogl15 (>= 1.15.8) but it is not installable
libcommon-sense-perl : Depends: perl (< 5.18.3~) but 5.22.1-9 is installed
libcompress-raw-lzma-perl : Depends: perlapi-5.18.1 but it is not installable
libcrypt-ssleay-perl : Depends: perlapi-5.18.1 but it is not installable
libcupscgi1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is installed
libcupsimage2 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is installed
libcupsimage2:i386 : Depends: libcups2:i386 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is installed
libcupsmime1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is installed
libcupsppdc1 : Depends: libcups2 (= 1.7.2-0ubuntu1.7) but 2.1.3-4 is installed
libcwidget3 : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
libdbd-mysql-perl : Depends: perlapi-5.18.2 but it is not installable
libdbi-perl : Depends: perlapi-5.18.1 but it is not installable
libdbus-1-dev : Depends: libdbus-1-3 (= 1.6.18-0ubuntu4.5) but 1.10.6-1ubuntu3.3 is installed
libdbus-glib2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libdecodeqr-examples : Depends: libopencv-core2.4 but it is not installable
Depends: libopencv-highgui2.4 but it is not installable
Depends: libopencv-imgproc2.4 but it is not installable
libdecodeqr0 : Depends: libopencv-core2.4 but it is not installable
Depends: libopencv-imgproc2.4 but it is not installable
libdigest-crc-perl : Depends: perlapi-5.18.1 but it is not installable
libecal-1.2-16 : Depends: libical1 (>= 1.0) but it is not installable
libedata-cal-1.2-23 : Depends: libical1 (>= 1.0) but it is not installable
libevent-perl : Depends: perlapi-5.18.1 but it is not installable
libexpat1-dev : Depends: libexpat1 (= 2.1.0-7ubuntu0.16.04.2) but 2.1.0-4ubuntu1.3 is installed
libffado2 : Depends: libxml++2.6-2 (>= 2.36.0) but it is not installable
libfile-fcntllock-perl : Depends: perlapi-5.18.1 but it is not installable
libflickrnet2.2-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libfont-freetype-perl : Depends: perlapi-5.18.1 but it is not installable
libgail-3-0 : Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.6) but 3.18.9-1ubuntu3.1 is installed
libgconf2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgconfmm-2.6-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
libgdata2.1-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgkeyfile1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libglade2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libglademm-2.4-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
libglib-perl : Depends: perlapi-5.18.1 but it is not installable
libglib2.0-bin : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.48.2-0ubuntu1 is installed
libglib2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libglib2.0-dev : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.48.2-0ubuntu1 is installed
libglibmm-2.4-1c2a : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
libgnokii7 : Depends: libical1 (>= 1.0) but it is not installable
libgnome-keyring1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgnome-vfs2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgnome2-canvas-perl : Depends: perlapi-5.18.1 but it is not installable
libgnome2-perl : Depends: perlapi-5.18.1 but it is not installable
libgnome2-vfs-perl : Depends: perlapi-5.18.1 but it is not installable
libgnome2.24-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgnutls28 : Depends: libhogweed2 (>= 2.7) but it is not installable
Depends: libnettle4 (>= 2.7) but it is not installable
libgstreamer-perl : Depends: perlapi-5.18.1 but it is not installable
libgstreamermm-1.0-0v5 : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
Recommends: gstreamer1.0-alsa but it is not installed
libgtk-sharp-beans-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgtk2-gladexml-perl : Depends: perlapi-5.18.1 but it is not installable
libgtk2-notify-perl : Depends: perlapi-5.18.1 but it is not installable
libgtk2-perl : Depends: perlapi-5.18.2 but it is not installable
libgtk2-trayicon-perl : Depends: perlapi-5.18.1 but it is not installable
libgtk2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libgtkmm-2.4-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
libgtkmm-3.0-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
libgtksourceviewmm-3.0-0v5 : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
libguard-perl : Depends: perlapi-5.18.1 but it is not installable
libgudev1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libhtml-parser-perl : Depends: perlapi-5.18.1 but it is not installable
libio-pty-perl : Depends: perlapi-5.18.1 but it is not installable
libjson-xs-perl : Depends: perlapi-5.18.1 but it is not installable
libk3b6 : Depends: libtag1c2a (>= 1.5) but it is not installable
libk3b6-extracodecs : Depends: libtag1c2a (>= 1.5) but it is not installable
libkcal4 : Depends: libical1 (>= 1.0) but it is not installable
libkcalcore4 : Depends: libical1 (>= 1.0) but it is not installable
libkde3support4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkdeclarative5 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkdesu5 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkdewebkit5 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkdnssd4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkf5activitiesexperimentalstats1 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5baloo5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5bookmarks5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5completion5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5configgui5 : Depends: libkf5configcore5 (>= 5.2.0+git20141003) but it is not installed
Recommends: libkf5config-bin (= 5.18.0-0ubuntu1)
libkf5declarative5 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Recommends: kpackagelauncherqml but it is not installed
libkf5emoticons5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Recommends: libkf5emoticons-bin (= 5.18.0-0ubuntu1) but it is not installed
libkf5globalaccelprivate5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5iconthemes5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
Recommends: libkf5iconthemes-bin (= 5.18.0-0ubuntu1) but it is not installed
libkf5kcmutils5 : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 5.7.0+git20150228.0110+15.04) but it is not installed
libkf5kdelibs4support5 : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.98.0) but it is not installed
Recommends: libkf5kdelibs4support5-bin (= 5.18.0-0ubuntu1) but it is not installed
libkf5khtml5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
Recommends: libkf5khtml-bin (= 5.18.0-0ubuntu1) but it is not installed
libkf5kiocore5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5kiofilewidgets5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5kiowidgets5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libkf5kipi30.0.0 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5newstuff5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5notifications5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5notifyconfig5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5package5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5parts5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Recommends: libkf5parts-plugins (= 5.18.0-0ubuntu1) but it is not installed
libkf5peoplewidgets5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5plasma5 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libkf5plasmaquick5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5runner5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Recommends: qml-module-org-kde-runnermodel (= 5.18.0-0ubuntu1) but it is not installed
libkf5service5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5su5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Recommends: libkf5su-bin (= 5.18.0-0ubuntu1) but it is not installed
libkf5sysguard-bin : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
libkf5texteditor5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.98.0) but it is not installed
Recommends: ktexteditor-katepart (= 5.18.0-0ubuntu1) but it is not installed
libkf5textwidgets5 : Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libkf5wallet-bin : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5wallet5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkf5xmlgui5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
Recommends: libkf5xmlgui-bin (= 5.18.0-0ubuntu1) but it is not installed
libkfile4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libsolid4 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkfilemetadata4 : Depends: libtag1c2a (>= 1.5) but it is not installable
libkfontinstui5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkhtml5 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkjsapi4 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkidletime4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkmediaplayer4 : Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libknewstuff2-4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Recommends: kdelibs5-data (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libknewstuff3-4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Recommends: kdelibs5-data (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkolab0 : Depends: libkolabxml1 but it is not installable
libkparts4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkprintutils4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkpty4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkrosscore4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkrossui4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libkscreenlocker5 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Recommends: kde-config-screenlocker but it is not installed
libksgrd7 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libktexteditor4 : Depends: libkdecore5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (= 4:4.14.16-0ubuntu3) but 4:4.13.3-0ubuntu0.3 is installed
libktpcommoninternals9 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libktplogger9 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libktpmodels9 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libktpotr9 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
libktpwidgets9 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libkutils4 : Depends: libkidletime4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkprintutils4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
libkwin4-effect-builtins1 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libkwineffects7 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
liblchown-perl : Depends: perlapi-5.18.1 but it is not installable
liblist-moreutils-perl : Depends: perlapi-5.18.1 but it is not installable
liblocale-gettext-perl : PreDepends: perlapi-5.18.1 but it is not installable
libmono-addins-gui0.2-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libmono-addins0.2-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libmono-sharpzip2.6-cil : Depends: libmono-corlib2.0-cil (>= 3.2.8) but it is not installable
libmono-zeroconf1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libndesk-dbus-glib1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libndesk-dbus1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libnet-dbus-perl : Depends: perlapi-5.18.1 but it is not installable
libnet-dns-perl : Depends: perlapi-5.18.1 but it is not installable
libnet-libidn-perl : Depends: perlapi-5.18.1 but it is not installable
libnet-ssleay-perl : Depends: perlapi-5.18.2 but it is not installable
libnetaddr-ip-perl : Depends: perlapi-5.18.1 but it is not installable
libnewtonsoft-json5.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libnotify0.4-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libnunit2.6-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libnux-4.0-0 : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
libopentk1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libpango-perl : Depends: perlapi-5.18.1 but it is not installable
libpangomm-1.4-1v5 : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
libparams-util-perl : Depends: perlapi-5.18.1 but it is not installable
libperl5.18 : Depends: perl-base (= 5.18.2-2ubuntu1.1) but 5.22.1-9 is installed
libperlio-gzip-perl : Depends: perlapi-5.18.1 but it is not installable
libplasma3 : Depends: libkdewebkit5 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libkdnssd4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
Depends: libknewstuff3-4 (= 4:4.13.3-0ubuntu0.3) but 4:4.14.16-0ubuntu3 is installed
libpowerdevilcore2 : Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
libpowerdevilui5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
libprocessui7 : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libpurple0 : Depends: perlapi-5.18.2 but it is not installable
Recommends: libpurple-bin but it is not installed
libqapt2 : Depends: libxapian22 but it is not installable
libqt53d5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5dbus5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5location5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5opengl5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5organizer5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5positioning5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5printsupport5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5sensors5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5sql5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5sql5-sqlite : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5svg5 : Depends: qtbase-abi-5-2-1 but it is not installable
libqt5xml5 : Depends: qtbase-abi-5-2-1 but it is not installable
libreoffice : Depends: libreoffice-java-common (>= 1:5.1.4~) but 1:4.2.8-0ubuntu4 is installed
libreoffice-base : Depends: libreoffice-base-drivers (= 1:5.1.4-0ubuntu1) but 1:4.2.8-0ubuntu4 is installed
Recommends: libreoffice-java-common (>= 1:5.1.4~) but 1:4.2.8-0ubuntu4 is installed
libreoffice-calc : Depends: libmwaw-0.3-3 but it is not installed
Depends: liborcus-0.10-0v5 (>= 0.9.2-4ubuntu2) but it is not installed
libreoffice-core : Depends: libclucene-contribs1v5 (>= 2.3.3.4) but it is not installed
Depends: libclucene-core1v5 (>= 2.3.3.4) but it is not installed
Depends: libcmis-0.5-5v5 but it is not installed
Depends: libeot0 but it is not installed
libreoffice-draw : Depends: libfreehand-0.1-1 but it is not installed
Depends: libmspub-0.1-1 but it is not installed
Depends: libmwaw-0.3-3 but it is not installed
Depends: libpagemaker-0.0-0 (>= 0.0) but it is not installed
libreoffice-impress : Depends: libmwaw-0.3-3 but it is not installed
libreoffice-officebean : Depends: libreoffice-java-common (>= 1:5.1.4~) but 1:4.2.8-0ubuntu4 is installed
libreoffice-writer : Depends: libabw-0.1-1v5 but it is not installed
Depends: libe-book-0.1-1 but it is not installed
Depends: libmwaw-0.3-3 but it is not installed
libsigc++-2.0-dev : Depends: libsigc++-2.0-0c2a (= 2.2.10-0.2ubuntu2) but it is not installable
libsocket6-perl : Depends: perlapi-5.18.2 but it is not installable
libsub-identify-perl : Depends: perlapi-5.18.1 but it is not installable
libsub-name-perl : Depends: perlapi-5.18.1 but it is not installable
libsubtitleeditor0 : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
libsys-syslog-perl : Depends: perlapi-5.18.1 but it is not installable
libtag-extras1 : Depends: libtag1c2a (>= 1.5) but it is not installable
libtaglib2.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libtaglib2.1-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libtaskmanager5 : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
libterm-readkey-perl : Depends: perlapi-5.18.1 but it is not installable
libtext-charwidth-perl : Depends: perlapi-5.18.1 but it is not installable
libtext-iconv-perl : Depends: perlapi-5.18.1 but it is not installable
libtext-soundex-perl : Depends: perlapi-5.18.1 but it is not installable
libtotem0 : Depends: libcogl15 (>= 1.15.8) but it is not installable
libubuntuone1.0-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
libunicode-string-perl : Depends: perlapi-5.18.1 but it is not installable
libuuid-perl : Depends: perlapi-5.18.1 but it is not installable
libxml++2.6-2v5 : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
libxml-libxml-perl : Depends: perlapi-5.18.2 but it is not installable
libxml-parser-perl : Depends: perlapi-5.18.1 but it is not installable
libyaml-syck-perl : Depends: perlapi-5.18.1 but it is not installable
libzeitgeist0.8-cil : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
milou : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
mono-2.0-service : Depends: libmono-corlib2.0-cil (>= 3.2.8) but it is not installable
Depends: libmono-posix2.0-cil (>= 3.2.3) but it is not installable
Depends: libmono-system2.0-cil (>= 3.2.1) but it is not installable
nemiver : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
openjdk-6-jre : Depends: openjdk-6-jre-headless (= 6b40-1.13.12-0ubuntu0.14.04.3) but it is not installable
paman : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
Recommends: padevchooser but it is not installable
paprefs : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
pavucontrol : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
pavumeter : Depends: libglibmm-2.4-1v5 (>= 2.44.0) but it is not installed
pdfmod : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
perl-tk : Depends: perlapi-5.18.1 but it is not installable
perlmagick : Depends: perlapi-5.18.2 but it is not installable
pidgin : Depends: perlapi-5.18.2 but it is not installable
plasma-dataengines-addons : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
plasma-desktop : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 5.7.0+git20150228.0110+15.04) but it is not installed
Recommends: fonts-noto but it is not installed
Recommends: fonts-oxygen but it is not installed
Recommends: kde-config-screenlocker but it is not installed
Recommends: kde-config-sddm but it is not installed
Recommends: kde-style-oxygen-qt5 but it is not installed
Recommends: kgamma5 but it is not installed
Recommends: ksshaskpass but it is not installed
Recommends: libpam-kwallet5 but it is not installed
Recommends: plasma-pa but it is not installed
plasma-framework : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
plasma-nm : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
plasma-widgets-addons : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
plasma-workspace : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 5.15.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
Recommends: libpam-kwallet5 but it is not installed
polkit-kde-agent-1 : Depends: libpolkit-qt5-1-1 (>= 0.112.0) but it is not installed
powerdevil : Depends: libkf5auth5 (>= 4.96.0) but it is not installed
Depends: libkf5configcore5 (>= 4.98.0) but it is not installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not installed
python-gi-cairo : Depends: python-gi (= 3.12.0-1ubuntu1) but 3.20.0-0ubuntu1 is installed
python3-pykde4 : Depends: libkcmutils4 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdecore5 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkdeui5 (>= 4:4.14.9) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkemoticons4 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libkio5 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libplasma3 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
Depends: libsolid4 (>= 4:4.14.2) but 4:4.13.3-0ubuntu0.3 is installed
qml-module-org-kde-activities : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
qml-module-org-kde-telepathy : Depends: libkf5configcore5 (>= 4.97.0) but it is not installed
qtbase5-dev : Depends: libqt5concurrent5 (= 5.2.1+dfsg-1ubuntu14.3) but 5.5.1+dfsg-16ubuntu7.2 is installed
Depends: libqt5core5a (= 5.2.1+dfsg-1ubuntu14.3) but 5.5.1+dfsg-16ubuntu7.2 is installed
Depends: libqt5gui5 (= 5.2.1+dfsg-1ubuntu14.3) but 5.5.1+dfsg-16ubuntu7.2 is installed
Depends: libqt5network5 (= 5.2.1+dfsg-1ubuntu14.3) but 5.5.1+dfsg-16ubuntu7.2 is installed
Depends: libqt5widgets5 (= 5.2.1+dfsg-1ubuntu14.3) but 5.5.1+dfsg-16ubuntu7.2 is installed
qtbase5-dev-tools : Depends: qtbase-abi-5-2-1 but it is not installable
rhythmbox : Depends: python3 (< 3.5) but 3.5.1-3 is installed
Recommends: rhythmbox-plugins but it is not installed
spamassassin : Depends: perl-modules (>= 5.10) or
libio-zlib-perl (>= 1.04)
step : Depends: libqalculate5 but it is not installable
subtitleeditor : Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installed
synaptic : Depends: libxapian22 but it is not installable
sysinfo : Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installable
texlive-binaries : Depends: libpotrace0 but it is not installed
Depends: libzzip-0-13 (>= 0.13.56) but it is not installed
thelastripper : Depends: libmono-corlib2.0-cil (>= 1.2.2.1) but it is not installable
Depends: libmono-posix2.0-cil (>= 2.4) but it is not installable
Depends: libmono-system2.0-cil (>= 2.4.3) but it is not installable
totem : Depends: libcogl15 (>= 1.15.8) but it is not installable
Depends: totem-common (= 3.10.1-1ubuntu4.3) but 3.18.1-1ubuntu4 is installed
unity : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable
Depends: libunity-core-6.0-9 (= 7.2.6+14.04.20160408-0ubuntu1) but 7.4.0+16.04.20160906-0ubuntu1 is installed
unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not installable
Depends: libcheese7 (>= 3.0.1) but it is not installable
unity-settings-daemon : Depends: gnome-settings-daemon-schemas (< 3.10) but 3.18.2-0ubuntu3.1 is installed
vlc-nox : Depends: libebml4 but it is not installable
Depends: libmatroska6 but it is not installable
Depends: libtag1c2a (>= 1.9.1) but it is not installable
wx-common : Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
zeitgeist-core : Depends: libxapian22 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

howefield
February 3rd, 2017, 10:43 AM
What other repositories do you have installed ?


egrep -v '^#|^ *$' /etc/apt/sources.list /etc/apt/sources.list.d/*

sleemanj
February 3rd, 2017, 11:13 AM
Hmm, yes there are a few, but moving sources.list.d out of the way and doing an update didn't help... do these need to be disabled in some explicit manner?

Edit: actually these are all .list.save files, so they are ignored anyway.


sources.list:deb http://archive.ubuntu.com/ubuntu/ xenial main universe restricted multiverse
sources.list:deb-src http://archive.ubuntu.com/ubuntu/ xenial main universe restricted multiverse #Added by software-properties
sources.list:deb http://archive.ubuntu.com/ubuntu/ xenial-updates universe main multiverse restricted
sources.list:deb http://archive.ubuntu.com/ubuntu/ xenial-backports universe main multiverse restricted
sources.list:deb http://security.ubuntu.com/ubuntu/ xenial-security multiverse restricted universe main
sources.list.d/daniel-elstner-sigrok-trusty.list.save:deb http://ppa.launchpad.net/daniel-elstner/sigrok/ubuntu trusty main
sources.list.d/freecad-maintainers-freecad-stable-trusty.list.save:deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu trusty main
sources.list.d/gezakovacs-ppa-trusty.list.save:deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu trusty main
sources.list.d/google-chrome.list.save:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
sources.list.d/js-reynaud-kicad-4-trusty.list.save:deb http://ppa.launchpad.net/js-reynaud/kicad-4/ubuntu trusty main
sources.list.d/mc3man-trusty-media-trusty.list.save:deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
sources.list.d/opera-stable.list.save:deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
sources.list.d/philip5-extra-trusty.list.save:deb http://ppa.launchpad.net/philip5/extra/ubuntu trusty main
sources.list.d/philip5-kubuntu-backports-trusty.list.save:deb http://ppa.launchpad.net/philip5/kubuntu-backports/ubuntu trusty main
sources.list.d/stebbins-handbrake-git-snapshots-trusty.list.save:deb http://ppa.launchpad.net/stebbins/handbrake-git-snapshots/ubuntu trusty main
sources.list.d/stebbins-handbrake-releases-trusty.list.save:deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu trusty main
sources.list.d/strukturag-libde265-trusty.list.save:deb http://ppa.launchpad.net/strukturag/libde265/ubuntu trusty main
sources.list.d/thomas_tsai-ubuntu-tuxboot-trusty.list.save:deb http://ppa.launchpad.net/thomas.tsai/ubuntu-tuxboot/ubuntu trusty main
sources.list.d/yannubuntu-boot-repair-trusty.list.save:deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu trusty main

howefield
February 3rd, 2017, 11:35 AM
Although the upgrader usually disables PPAs prior to the upgrade taking place it doesn't revert the software back to the default Ubuntu versions, hence the dependency issues that you are seeing.

I'd suggest using ppa-purge to uninstall the PPAs and revert the software packages back to those from the Ubuntu repositories. It's a fair bit of work and I'd probably just do a fresh install.

https://blog.simos.info/how-to-completely-remove-a-third-party-repository-from-ubuntu/

sleemanj
February 3rd, 2017, 11:59 AM
:-(

I don't have ppa_purge installed on the b0rked system even if it could work with the broken deps, and the 4gig of upgrade debs it spent half a day downloading are not even in /var/cache/apt/packages any more it seems so that's more wasted effort.

You might be right, nightmare scenario as it is, discarding my 12 year updated ubuntu system with all it's various local configurations and do a fresh install might be the only way forward. Sure does leave a nasty taste in one's mouth.

I guess the only saving grace is that more by luck than planning I didn't do this "suggested upgrade" on my live system so I'm not totally boned.

howefield
February 3rd, 2017, 12:04 PM
I don't have ppa_purge installed on the b0rked system

As explained in the link above, it should be installable.


sudo apt update

sudo apt install ppa-purge

PPAs are a great for what they are, but there are downsides :(. The further away from a stock installation you get, oftentimes the harder things become.

sleemanj
February 3rd, 2017, 12:09 PM
As explained in the link above, it should be installable.


Unfortunately not, because of the broken dependencies apt will not install new packages.

ian-weisser
February 3rd, 2017, 02:07 PM
PPAs are not supported software, use them at your own risk...and this is one reason why. Some PPAs break upgrades.

Since you have numerous package conflicts to the point where apt no longer works, then you must uninstall all the non-Ubuntu software (including PPA software) using dpkg. Remember to clean out your local package cache to prevent PPA software from getting reinstalled.

Looking over your error messages, it would should take you around three or four hours to remove amarok, amarok-utils, qt-5, and the rest using dpkg. Do it from a TTY, not a terminal window - your GUI desktop is likely to break along the way. Then reinstall kubuntu-desktop to restore your functioning system. Then it will be ready for an upgrade

Alternately, install fresh. It will be faster and easier for you. Completely uninstall all PPA software, and disable PPA sources for that software before upgrading next time.

Either way, preserve all your data first with a backup! Both paths risk data loss if you make a typo.