PDA

View Full Version : Trouble installing RStudio



casaj2
January 14th, 2017, 02:34 PM
Hi all, new Ubuntu user here so please bear with me. When trying to install rStudio through the terminal I am getting the following errors:

dpkg: dependency problems prevent configuration of rstudio:
rstudio depends on libjpeg62; however:
Package libjpeg62 is not installed.
rstudio depends on libgstreamer0.10-0; however:
Package libgstreamer0.10-0 is not installed.
rstudio depends on libgstreamer-plugins-base0.10-0; however:
Package libgstreamer-plugins-base0.10-0 is not installed.

dpkg: error processing package rstudio (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.7-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'

casaj2
January 14th, 2017, 03:53 PM
pls respond

steeldriver
January 14th, 2017, 04:21 PM
Please be patient

This is a volunteer forum - there is no guarantee that someone with insight into your problem will be active on the site at any particular time

Meantime, please describe exactly how you are trying to install rstudio (PPA? .deb? from where?) - what is the exact command you are typing? Please also include information about the version of Ubuntu that you are using.

casaj2
January 14th, 2017, 04:24 PM
Installing through the terminal.

the commands are as follows

sudo apt-get install gdebi-core
wget https://download1.rstudio.org/rstudio-1.0.44-amd64.deb
sudo gdebi -n rstudio-1.0.44-amd64.deb
rm rstudio-1.0.44-amd64.deb

and I am running the latest version of ubuntu: 16.10

casaj2
January 14th, 2017, 05:37 PM
I managed to fix the problem.

There was an error in the software from a 'ppa.launchpad.net' location which did not have a release file. After removing it from the other software tab of software and updates I was able to install Rstudio without a problem.