View Full Version : 16.10 incredibly slow install.

January 9th, 2017, 01:12 AM
When I say slow - I mean watching paint dry slow. I can take more than a minute from clicking on a button to seeing the twirly hourglass equivalent, and 5-10 minutes to get to the next screen.

The slows seem confined to to the UI aspects of setup - get to copying files etc and that seems to proceed at normal speed (I think).

I have seen this multiple times on several different laptops.

All my attempts have been to newer UEFI laptops - I have not tested on an older one yet.
Several installs involved creating the USB install driver by dd'ing the ISO to the thumbdrive.

The last used Rufus to create the thumb drive.

January 11th, 2017, 11:19 PM
Running something (the install) from USB flash is not necessarily instantaneous (not like internal SSD).

But I did run across one install of 16.10 from a live session on USB that was sluggish and seemed to hang at some point, maybe after I entered my user info, before the next step. I opened System Manager and it showed all 4 threads running at 100%, but in the list of processes, the biggest thing that showed in order of CPU use was compiz at 25%, so the culprit did not show up in System Monitor. I opened a terminal (Ctrl-Alt-T) and top showed a load ave of something like 4.53 and 4 instances of a process called cc1 I think (could it be /usr/lib/gcc/x86_64-linux-gnu/6/cc1?).

I forget how I stopped the install, but once the system settled down without rebooting, I ran the install again and it worked fine. During the install an error popped that it was going to report, but it disappeared before I could tell what it was for. It may have been related to graphic of features of the version NOT showing up in the install box (the box was empty other than download/install status at bottom). Anyway, the install itself went fine and I am posting from the installed 64-bit 16.10 system.

January 12th, 2017, 12:00 AM
First, this problem is SPECIFIC To Ubuntu - possibly to Ubuntu 16.10 - I did not try 16.04, but I have not had this problem with earlier versions of Ubuntu.

Second - when I say SLOW, I mean unbelievably incredibly SLOW. As noted int he original posts - it can take MANY minutes from Clicking "continue" to the button changing state to changing to the next page.

The problem is not specific to a one USB stick - I have tried numerous sticks.

Further I have put Debian/Jesse on the Same USB Sticks and installed the entire system in less time than it takes to answer the first question installing Ubuntu.

Nor is this problem specific to an individual machine. I have had exactly the same problem with 3 different HP Laptops from brand spanking new to 3 years old.
Each system having atleast 16GB of DDR.

All the Installs I have tried have been boot directly into the installer.
But if I had the option to run system manager - I would likely be dead before ti got to the point of telling me what processes were running.
Put differently things were so slow that even trying to debug was impossible.

I beleive that in one instance - taking many hours I eventually succeeded in installing.
The resulting Ubuntu 16.10 performed acceptably on that machine.

Some additional information:

All installs were amd64 - to 64 bit systems.

I beleive that all were to UEFI machines - but I have not tried to an non-UEFI machine to see if that fixes the problem.

I think all attempts were to HP laptops.

I have also separately installed Ubuntu 16.10 from the same "iso immage" into a virtual machine - with only the normal slows associated with installing a virtual machine.

February 14th, 2017, 05:51 AM
Ditto "When I say slow - I mean watching paint dry slow." booted to thumb drive, selected update 16.04 to 16.10, three days and still on saving installed packages page. used Rufus to create the thumb drive iso from Win 10.
Any more ideas?