View Full Version : [SOLVED] Usual ntfs partitions automatically mounted as read-only since not long

January 1st, 2017, 08:30 AM

Dual boot with two disks, four main partitions, two of which ntfs.
The ntfs partitions automagically appear on my desktop, which is nice. Until recently, just double-clicking on the corresponding icon would open them in read-write mode, which was nice. Long story, I made a fresh instal of everything. Xubuntu is now 16.10 and Windows version 10, which is also nice.
Still have the ntfs icons, but now they stubornly open them in read-only mode, which is not nice.

I suppose I could mount them manually, although it's been some time since I last did that and I would need a bit of thinking.
Right now, said partitions are not listed in
fstab. I suppose I could add them there, but for reasons, I'd rather not.
When installing, I may or may not have omitted to install some anciliary package like
ntfs-3g but my previous configuration was the result of continuous upgrades since times imemorial so I've forgotten where to start looking.

Hence questions :

* Why is that ? Is it something new with 16.10 ?
* How can I reinstate the previous behaviour, to wit double-click => auto-mount r/w ?

cheers + thanks

January 1st, 2017, 08:34 AM
Thread moved to Installation & Upgrades.

January 1st, 2017, 02:11 PM
The 'ntfs-3g' software is required to write to any proprietary ntfs filesystem so I would start with installing that.

January 1st, 2017, 04:05 PM
* Why is that ? Is it something new with 16.10 ?
* How can I reinstate the previous behaviour, to wit double-click => auto-mount r/w ?

I don't think it's something new with Ubuntu 16.10. I think it's something new with Windows 10. It has fast startup enabled by default, to hide the fact Windows 10 boots so slow. With fast startup enabled, Windows doesn't cleanly unmount its file systems. As a result of that Ubuntu cannot mount these ntfs partitions in read-write mode. It should be possible to disable this setting in Windows.

You may also want to make sure that ntfs-3g is installed, although I think that it's supposed to be installed by default and without it the ntfs partitions woundn't be mounted at all.

January 1st, 2017, 04:32 PM
Just to add to Impavidus' suggestion.

Fast Start up off (always on hibernation)

(http://askubuntu.com/questions/843153/ubuntu-16-showing-windows-10-partitions)Be sure to create a Windows repair/recovery flash drive.
Windows on updates may turn the fast start back on. Or NTFS may need chkdsk.
Windows 10 repair disk

January 2nd, 2017, 08:42 AM
Thank you for this detailed answer, and thank everybody else for the hints. Sure enough, the culprit was Fast Boot. I disabled it in the control panel, problem solved.
I had indeed noticed that Windows started surprisingly fast, wich was nice but suspicious.

Damn Windows, acting like it owns the place and was alone in the world.

Spot on :-)