View Full Version : Help, Grub-rescue error: invalid arch-independent ELF magic

December 23rd, 2016, 04:19 AM
Thank you for taking the time to read this. I'm pretty new to Linux and Ubuntu. I am running 16.10 on an old repurposed Dell Laptop (I5 ssd,etc). I received updated two days ago, and the kernel version went from to It hasn't booted properly since. I must have destroyed what little was left because now I get to "Grub rescue" without using the Live cd, which boots fine and everything is still there. I tried to re-install yesterday but after 24 hours of it trying I gave up and force restarted. Back to live cd working fine.

I tried several answers in thread that looks like they pointed at fixing UEFI, I learned that I have Legacy boot enabled, but not sure what all that means.

December 23rd, 2016, 05:35 AM
Elf magic is often trying to boot in wrong mode.
Did you change from BIOS/CSM/Legacy to UEFI or vice-versa in UEFI?

May be best to see details, you can run from Ubuntu live installer or any working install:
Post the link to the Create BootInfo summary report. Is part of Boot-Repair: