View Full Version : [SOLVED] Could not opn Lock file?

December 18th, 2016, 06:24 AM
Hello everyone,

I've recently purchased a new desktop computer for the coding and computer programming courses i'm going to take online, ive decided to use vim as my IDE and in the process of downloading my vim stuffs I came across this error message after trying to install the "apt-get install python-pip"

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

i am new to the ubuntu comunity

thanks in advance mates

December 18th, 2016, 06:29 AM
The command is sudo apt-get install package name, after you enter the command it will ask for your user password, type the password it will not show it as you type so when you are done hit enter.

The sudo command gives you root temporarily, I believe 15 minutes is the limit.

December 18th, 2016, 06:51 AM
thanks, it works perfectly

December 18th, 2016, 06:54 AM
Please use thread tools at the top of the page to mark the thread solved.