View Full Version : Ubuntu 14.04 LTS installation stuck (on loading dots)

September 5th, 2016, 04:36 AM
Hello, I am currently trying to install Ubuntu (for a dual boot) on a new drive that I bought for my laptop (it is internal) but it gets stuck on the loading screen. This is the screen with the white and orange dots in it. The dots start changing color but when they are somewhat half white, half orange they all turn orange and then the installation won't respond to anything forcing me to do a force shut down on the machine. I am using a USB drive for this since my laptop does not have an optical drive. I have also tried downloading and burning the ISO time after time to no avail. However, I tried running the installation on another computer to see if it worked and it did right off the bat so that discards the USB or the ISO being the problem here. Could I get a suggestion here? Because I have been trying all weekend and am starting to give up.

If this helps anyone, my computer is a Clevo Laptop with:

intel i7 6700HQ CPU @ 2.6GHz
Nvidia Geforce GTX 970
16 gb RAM
1 tb HDD
256 gb m.2 San Disk SSD (the one I want to install Ubuntu on)
480 gb m.2 MyDigitalSSD SSD (the one I have Windows installed on)

September 5th, 2016, 11:34 AM
Ah, the joys of forum glitches.

You have some replies here: https://ubuntuforums.org/showthread.php?t=2336142