View Full Version : [ubuntu] Installing Ubuntu 16 in "legacy mode" means no BIOS acces, No USB booting

Finn bjerke
August 20th, 2016, 07:53 PM
I can boot in EUFI mode or Legacy on my new Aces machine. I installled Ubuntu 16 and wiped oput Win10 by using "legacy mode" in bios. Now I have no bios acces and can not boot from USB, Ubuntu 16 works well but upgrading is a problem. Any suggestions.

Win10 makes UEFI install almost impossible so dual boot is very difficult. I am not patient enought to read a lot of technical stuff, so legacy install semmed the easy solution, If you want to overrule WIN10 bios controle in UEFI mode things get complicated.

I need BIOS acces

August 20th, 2016, 11:29 PM
Did you get a user manual with the computer? Might be a good place to start. You could also post more specific information on exactly which Acer you have since they make many different models of Desktop. Laptop and notebooks.

August 21st, 2016, 05:23 AM
BIOS mode with UEFI is still UEFI, just emulation of the 35 year old BIOS.
CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode

So you may still have fast boot setting on in UEFI. That assumes you have made no changes to system, so UEFI does not spend any time re-checking system. But then you also do not have any time to press the correct key(s) to get into UEFI/BIOS to change settings.
Most will give you time with a full cold boot, not the warm reboot.
With a laptop you have to also remove battery & hold power switch for 10 sec or so to totally drainl all power. Then on boot immediately press correct key to get into UEFI.


Finn bjerke
August 22nd, 2016, 10:34 AM
Thank you for kind advice, I found this solution:

1. Swtich off PC, no rebooting.
2. Press F2
3. AFter F2 hit power botton.
4. In boot process press F2 in a "morse fashion" press - let go - press -let go. 1 secund for each
5. Et VOILA: BIOS is on, NOw find the function where you have F12 access to boot sequens enable that function.

Installing UBuntu in UEFI mode is blocked by Windows since Acer has preinstalled Windows i such a way, Guarantee is not valid when you install Ubuntu.

oldfred have a good point maybe its a fast boot problem, this "fast booting" in UEFI mode assumes windows is present I guess. Changing that is probably possible but complicated ? Maybe I could have fast acces turned off and install Ubuntu in EuFI mode that way, I belive i tried that with no succes. This new PC has the battery hidden away There is no direct battery acces. so I need a screw driver to get the battery out. Annoying. However the power button seems to kill all and reboot.

Finn bjerke
August 22nd, 2016, 10:34 AM
This a solved problem how do I indicate that ?

August 22nd, 2016, 10:42 AM
Congratulations and thanks for sharing your solution :KS

Please click on Thread Tools at the top of the page and mark this thread as SOLVED

August 22nd, 2016, 05:28 PM
Many with Acer have installed in UEFI boot mode.

Acer Trust Settings - details:
Boot Parameter required
Acer E3-112-C0MQ - Bay Trail Issue Boot Parameter required

Screen shots of Solved