View Full Version : [SOLVED] Boot Issue

May 4th, 2016, 09:22 PM
Hi, I installed ubuntu mate on a laptop with windows 10 of it uses UEFI this time ubuntu intalled with UEFI enabled instead of legacy so I had a little hope it would boot correctly.

However whichever OS I want to boot has to be in the first boot position or it will not boot. I have to go into setup everytime I want to switch from ubuntu to windows.
I ran the boot script and the out put is at the link.
Thanks for all help! I hope to resolve this I have been having to go into to setup to change fro ubuntu to windows by changing UEFI to legacy for the last 3 years or so but now I am having to us windows more so it is more inconvenient.

I did run boot repair but that just added a lot more entires to the grub menu and I received a message saying the repair failed.

May 4th, 2016, 10:10 PM
Hello Wild Man, I've ask this question seeing I have the same problem with one of my machines, I was told you probably need to install Ubuntu in the same boot order as Windows ether in UEFI or Legacy. I decided to leave mine as it is because i don't really use Windows that much but I'm kinda interested to see how you can fix this problem

I'm sure there must be an easier way to accomplish this

May 4th, 2016, 11:11 PM
First, add yourself to bug 1091464, "Unable to chainload Windows with secure boot enabled". Then disable secure boot. Edit /etc/fstab and remove the # (comment) on the /boot/efi mount. Use the EFI menu at power-up (some function key) to select ubuntu, it should boot. use efibootmgr to put the ubuntu entry (number 5) to the first place, or second after usb, but before Windows. That should be a working setup for a UEFI boot. If your specific machine strays from the standard UEFI path, because of vendor #@$%..., try looking for the solutions involving renaming the "ubuntu" boot entry to "Windows Boot Manager", maybe rename the shimx64.efi to bootmgfw.efi, and best to do anyway, copy the contents of /EFI/ubuntu to /EFI/Boot, rename any existing bootx64.efi to bootx64.efi.save, and rename the /efi/Boot/shimx64.efi to /EFI/Boot/bootx64.efi. More details on many threads here, if those steps are necessary

May 4th, 2016, 11:14 PM
I see Gateway.
And the few Gateways seem to have a limited UEFI.
But it is part of Acer, so may have the same UEFI requirement of setting UEFI supervisory password and enabling trust?
Is it also an InsydeH20 UEFI ?

Acer also had issues with one version of UEFI. Early posts said to downgrade UEFI to previous, but newer posts said very newest UEFI works. Have you downloaded newest UEFI?
One of several with more details:

May 5th, 2016, 12:40 AM
No, I have not downloaded the newest UEFI but I will give that a try.

May 9th, 2016, 05:21 AM
I have done everything that I can with this gateway and it looks like I will have to go into setup and change the boot order when I switch from ubuntu to windows but I can live with that.
Thanks everyone for your help.

May 9th, 2016, 04:02 PM
Does system not have a one time boot key like f10 or f12. My Asus motherboard uses f8. So you do not have to go into UEFI/BIOS, but just choose when rebooting.

If UEFI has fast boot setting (not the Windows fast start up), that must be off, or it boots too quick to have time to press a key.

My motherboard has separate fast boot settings for both cold boot & warm reboot and also a delay on fast boot which I set to 3 sec on reboot and normal boot on cold boot. And set grub to 3 sec/

May 11th, 2016, 12:39 AM
Does system not have a one time boot key like f10 or f12.I tried the f keys but they did not work.

I went into setup and there is nothing I can change except boot order well I knew it was dangerous but I reset the bios that I believe where changed when I installed ubuntu mate, after which I can now only boot windows.

Should I run boot repair again or what is your best guess.

Edit: When it is turned on I get a message HDD is not accessible due to security polices.
So I am guessing secure boot is causing the issue.

May 11th, 2016, 04:36 AM
I have with both old BIOS and new UEFI installed updates and the updates reset everything to system defaults. And in both systems, I had many settings that I had changed. With old BIOS I had to take photos to remember all settings. My UEFI spits out a list of changes on save and also has screen shots.

But if you reset to defaults, it almost for sure turned Secure boot back on. If you previously had changed other settings, you probably have to update those also.

May 11th, 2016, 05:06 AM
I ran boot repair and I can now boot both OS's again. I found a setting in setup that let me turn on f12 as my boot menu key so I can now hit f12 and choose which system to boot.
Thanks everyone for your help especially oldfred.

May 11th, 2016, 05:20 AM
Glad you got it working. :)