PDA

View Full Version : [SOLVED] dpkg-deb error on routine system update



Kestreln8144
April 1st, 2016, 09:34 PM
I have 14.04 Trusty.

While running a routine sudo apt-get update && sudo apt-get dist-upgrade, I ran into this error:


Unpacking libefl (201603312131-31982~ubuntu14.04.1) over (201603242131-31876~ubuntu14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/libefl_201603312131-31982~ubuntu14.04.1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/libelementary.so.1.17.99', which is also in package libelementary 201603242216-12490~ubuntu14.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libefl_201603312131-31982~ubuntu14.04.1_amd64.deb


Running sudo apt-get -f install gives the same error.

What might've caused this?

Kestreln8144
April 2nd, 2016, 12:10 AM
I've fixed it.

I have elementary libs installed because I use Terminology. I don't know how this problem occurred, but here is what I did:

sudo dpkg -r libelementary
sudo apt-get purge terminology
sudo apt-get autoremove
Restart machine.
sudo apt-get install terminology


And the packages appear to have installed correctly. (And Terminology works.)

RobGoss
April 2nd, 2016, 12:21 AM
Glad you got it sorted out would you mind marking this thread as solved? Just view the Thread Toll option at the top right hand side of this post. Thanks so much

Kestreln8144
April 2nd, 2016, 01:58 AM
Glad you got it sorted out would you mind marking this thread as solved? Just view the Thread Toll option at the top right hand side of this post. Thanks so much

I did immediately after posting my solution, and I can see it marked as solved. Is it not showing up for you?

RobGoss
April 2nd, 2016, 02:42 AM
Yes it is thank you very much