View Full Version : [SOLVED] Win 10 / Ubuntu Studio Dual Boot issues

March 10th, 2016, 06:19 PM
Greetings programs!

I am having issues trying to get Windows 10 / Ubuntu Studio to boot following an upgrade from Windows 7.

Originally I couldn't boot either so I followed the instructions to do a recommended boot repair and that got me back into Windows 10 which was working well (well as well as Windows 10 can work). Following this GRUB disappeared so today I tried to restore it by repeating the repair process however this has resulted in me again being unable to boot into either (just a flashing _ shown).

Here was my boot info with Windows 10 working prior to the boot repair to restore GRUB:

Following the attempted repair this was the boot info:

I then tried the repair again (no change, neither bootable and still just a flashing _):

I would be most thankful if someone could advise on how I could restore both Windows 10 and Ubuntu Studio. Failing then just restoring Windows 10 again and I can look at sorting/re-installing Ubuntu Studio as I currently have nothing worth saving on it.


March 10th, 2016, 07:20 PM
For Windows to boot, boot flag must be on primary NTFS partition with boot files which looks like sda1, but you have boot flag on sda5. Use gparted to move boot flag or Windows repair (set active is what Windows calls boot flag). Grub does not use boot flag.

Install of Windows 10 on BIOS system has same bug Windows has had for years. Any major update in Windows rewrites partition table and it conveniently forgets to include the Linux logical partition. Partition is still there, but not in partition table.
Usually testdisk or parted rescue can restore partition and then Boot-repair or a reinstall of grub works.

Some using testdisk restore incorrect set of partitions, best to have backup of current set of partitions, so worst case you can start over.
backup before any changes, so you can get back to current if changes not correct
sudo sfdisk -d /dev/sda > PT_sda.txt

These all are essentially the same, some may show more info. Some are testdisk others parted rescue, either should work.

Windows 7 to Windows 10 MBR partition missing
Use parted rescue to restore missing partition details in post #22
Parted rescue seems easier than testdisk

March 11th, 2016, 03:31 PM
Thanks for the advice oldfred, I've managed to get back into Windows 10 by setting the boot flag on sda1 (ended up using fdisk option a).

I am still working through the information in the links you provided but will let you know how I get on.

March 12th, 2016, 07:34 PM
Sorted! Thanks oldfred.
Basically followed the advice above:
1) In linux boot-repair rescue USB set the boot flag off on sda5 and on on sda1 using parted.
2) Used parted rescue option on ext4 which was appearing as unallocated space.
3) Carried out the recommended repair option using boot-repair.

March 12th, 2016, 10:35 PM
Glad that worked.

You can change thread to Solved.

March 13th, 2016, 04:02 AM
the way I learned how to make a successful dual boot system is to make Windows boot up first and then let grub alter the boot partition for linux.