PDA

View Full Version : Booting Problem: Toshiba Satellite Windows 10 Upgrade



jospph
March 10th, 2016, 05:49 AM
I have a Toshiba Satellite laptop with W10 upgrade. My problem is that I can boot to the USB drive, and it will show the boot menu from the USB drive but it will not show anything but a black screen afterwards. Any thoughts?

Bucky Ball
March 10th, 2016, 06:29 AM
Welcome.

Confused. You boot what from the USB drive? Ubuntu installer? Which version/flavour? Have some suggestions once confirmed, but if you are trying to boot Ubutnu, try this.

Boot the USB,
When you get to the purple screen with the icon down the bottom, hit a key,
When at the options, hit F6,
Choose 'nomodeset' from the menu that pops up,
Continue to 'Try Ubuntu'.

oldfred
March 10th, 2016, 04:11 PM
Is it an upgrade from Windows 7 so probably BIOS boot?
Or an upgrade from Windows 8 so UEFI boot?

You want to boot Ubuntu live installer in same boot mode as Windows install. As Ubuntu installs in mode you boot install media and you really want all systems booting in same boot mode.

jospph
March 11th, 2016, 05:18 AM
When I make my selection I get nothing but a black screen.

jospph
March 11th, 2016, 05:21 AM
Oh and it is Ubuntu 12.04

Bucky Ball
March 11th, 2016, 05:24 AM
Is it an upgrade from Windows 7 so probably BIOS boot?
Or an upgrade from Windows 8 so UEFI boot?



And? We can't help you if you don't help us. Please address oldfred's questions so he can help.

jospph
March 11th, 2016, 05:35 AM
Okay, before I continue to go into any more details of my issue:

I apologize for the duplicate post. I'm new so I didn't exactly know if I would see replies in my notifications/email or not (which I did not from either. I know now how to check them)

Reply to 'oldfred'-
It was an upgrade from Windows 8.1 (that's all I know)

jospph
March 11th, 2016, 05:53 AM
Yes, it is UEFI boot.

oldfred
March 11th, 2016, 02:35 PM
Make sure Windows fast start up is off.
Fast Startup off (always on hibernation)
http://www.tenforums.com/tutorials/4189-fast-startup-turn-off-windows-10-a.html
http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.htmlold

(http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.htmlold)
Do you know what video you boot with Intel, AMD, nVidia?
At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
http://ubuntuforums.org/showthread.php?t=1613132
(http://ubuntuforums.org/showthread.php?t=1613132)
# Usually nVidia or AMD work with this:
nomodeset
# Usually Intel works with one of these:
i915.modeset=0
i915.i915_enable_rc6=1
video=1280x1024-24@60 # but change to your monitor size not 1280x1024
video=VGA-1:1280x1024-24@60 # but change to your monitor size


(http://ubuntuforums.org/showthread.php?t=1613132)

jospph
March 12th, 2016, 11:25 PM
It is AMD

oldfred
March 13th, 2016, 02:40 PM
If newer UEFI, much better to use newest version of Ubuntu, or 14.04.4, 15.10 or if just experimenting even 16.04. the 16.04 will not be released until April but has many updates that make very new hardware work without extra effort.

For AMD you may find lots of instructions to install fglrx driver, do not install it. Open source driver works for most.
With 15.10 Release notes
AMD's fglrx driver does not work with the current kernel
The fglrx driver is now deprecated in 16.04, use radeon and amdgpu

jospph
March 17th, 2016, 12:44 AM
I fixed it! I just changed the sleep setting in the bios screen and, BAM! It worked 😉
Thank y'all for your help!

Bucky Ball
March 17th, 2016, 04:15 AM
Excellent. Please see the first link in my signature below and mark thread as solved to help others. Good luck.