View Full Version : [SOLVED] 15.10 Wont boot - Missing boot loader

February 29th, 2016, 11:11 PM
Hi everyone,

I have done some initial reading up on previous similar problems from previous posts, but I cant quite make heads or tails to my own problem, so my apologies if this problem has been posted and solved exactly before.

I am using an Acer E5-522g laptop that previously had Windows 8 installed, and wanted to switch to Ubuntu has it did not have an activated Windows copy and didn't want to buy. I have successfully installed Ubuntu 15.1 on 3 other devices using this boot cd, but this time after what I thought was a successful install, after restarting the device does not recognize any bootable drive.

this is the boot info for the laptop currently.

From this I can see that no boot loader is installed in the MBR /dev/sda; is this the main cause of the problem? And if so, how come this was not an issue before?

I have also disabled secure boot from the bios.

Any help at all will be very much appreciated !

Many thanks

March 1st, 2016, 12:11 AM
Missing the MBR in UEFI is no problem, you have all the UEFI bootloaders in sda1. Try turning off legacy/compatibility mode and boot in UEFI mode.

March 1st, 2016, 12:36 AM
Acer requires you to set "trust" on Ubuntu/grub's efi boot files.

All these threads are really the same on setting password & trust.

Very latest UEFI/BIOS works, downgrade not required:
Acer E5-573G, downgrade UEFI, supervisor password & trust on Ubuntu efi boot files.
Acer Aspire E15 will not dual boot
Acer Aspire E 15 Downgrade to older UEFI, password & trust (ACPI issues?)
Acer Aspire ES1-512-C39M Details on supervisor password and settings to enable trust on ubuntu entries Also R14 model same fix
One of several with more details:
h (http://acer--uk.custhelp.com/app/answers/detail/a_id/27071/~/how-to-enable-or-disable-secure-boot)

March 1st, 2016, 08:17 AM
Thank you for the replies - interesting info about Acer. I will look into this over the day and reply with any success.