View Full Version : [kubuntu] Two 14.04 to 15.10 Automatic Upgrades Crashed! Why?

February 27th, 2016, 11:52 PM
Lost ability to attach to and Sound Output on Laptop. Decided to try and fix that if I could find a way. Then decided to update/upgrade all packages first. So ran series of sudo apt-get commands:

sudo apt-get -qq update
sudo apt-get -qq -y dist-upgrade
sudo apt-get -y autoremove
sudo apt-get -f install
sudo updatedb
sudo /bin/update-manager

These are my customary set of update/upgrare command I put into at text file and mark as execute under permissions and run as a script from a terminal window. Or if I am in a hurry, just run from my desktop using "ask" as my dconf-editor setting and picking "Run in Terminal" as my option. The "Display" option is also great as you can edit the file if need be. The "Run" option less so, because if user input is needed, that doesn't happen. But some of the embedded commands will work. so it can still be useful.

But since I apparently had a problem, I decided to run each apt-get command separately in a separate Terminal window, so I repeated the process but picked "Display" instead. Then I did a Replace All of "-qq" with "" and ended up with
sudo apt-get update
sudo apt-get -y dist-upgrade
sudo apt-get -y autoremove
sudo apt-get -f install
sudo updatedb
sudo /bin/update-manager

I did not save this. This was to be temporary. What I did was copy & paste each sudo apt-get line separately into a opened terminal window and pressed Enter, then waited for the command to complete. I wanted to see what was actually taking place, which is why I removed the -qq's. If something seemed wrong, I could back up to the last command using the up-arrow key and add " | less" to the line, execute it again, then scroll up and down the same repeated command and see each line as to what actually happened.

I go into this detail to help others see some options for themselves going forward. The first line of
sudo apt-get update Really only tells you if you got to all the repositories to fetch updates or not, and details of that nature. That's important, but as usual, it all seemed to be good.

The next command
sudo apt-get -y dist-upgrade brought a surprise though. It ran, but at the end, I read that 59 packages were not upgraded and one package had been suspended. This was not usual, and it had not been reported before.

I would not have seen it if it had been, because you have to do this stuff manually from a terminal window and see for yourself, look at the logs, or write filters and use temporary files to capture the bad news when it happens. I had not done all that because it takes some doing and is not normally needed. To me, it looked like 14.04 was in trouble. I was on the verge of trouble myself with the sound. What was going on?

The answer that came to mind was: 14.04 must be nearing end of life in terms of support. So I checked on-line, and sure enough, it's end of life is August 2016. That's a few months away, but apparently the support or improvements for it were already beginning to slip. Not too surprising, because Linux is about helping and being helped and sharing, meaning people have choice in this matter. So maybe it was time to upgrade and see if that helped.

So I started Software Updater, which is the formal name of /bin/update-manager. And under Settings, I changed my option from "For Long Term Support Versions" to "For New Versions". This I knew would bring me to the newest stable release, which is 15.10. Then I rebooted the PC and opened the Software Updater again. And I clicked the Upgrade button. Thus began the lengthy process of replacing 14.04 with 15.10 code.

I was warned that I should back up my account and data first, but I'm now accustomed to resurrecting my files from the ruins, so skipped that. But it is good advice. Only problem is, they tell you what you should do, but do not offer to do it for you, or tell you what is needed to get it done. You have to learn that for yourself.

With that going, I decide to fire up the other laptop and start it's 14.04 upgrade as well. When Software Updater comes up, I see I have updates waiting. These will be just 14.04 updates, but no harm in doing that first. It's won't take long. I change the Settings first though, so that after a reboot, it will offer the upgrade option from 14.04 to 15.10.

This is the only difference in the procedures followed between the two upgrades, but it made a big difference in the outcomes. The 1st PC was only a couple of days behind on updates, but it made a world of difference.

When I got back to the 1st PC, it was frozen with a blank grey screen. It had gotten far enough into the upgrade process that I knew it must have completed, so I waited awhile, then decided it needed help. Toying with Ctrl+C, Ctrl+Alt+Del, and finally the power button, it finally reacted with the Ubuntu dots page, like it was trying to shut down, but other than the dots progressing, nothing happened.

I finally killed power by holding the power button down for 10 seconds, then powered up again. It began fine, but then hung. One alternate boot option showed a new page was being loaded but it never appeared. Another showed modules loading but there were many error messages in there, never the same as I repeated these attempts.

Yet each retry seemed to progress further. I finally had a chance at loging into a terminal window, but what to do now? I could not log in as root, as the root password is not advertised, so unknown to me. I could log in as myself, as my account was unaffected by all this, so I did, Then I did "sudo su root" and took over as root.

What next? My best successes always seem to go straight to apt, apt-get, and dpkg, so I decided to start there. The only command I knew that might help was "apt-get install -f". If it couldn't help, it could at least suggest, and it did. It said to try "dpkg --configure -a", so I tried that. That was the key. It began putting the pieces together again. But it was not enough. Between these four commands, performed almost in random order over and over, I brought the failed upgrade back from ruin to a healthy state:
apt-get install -f # or apt-get -f install, same thing
dpkg --configure -a
apt-get dist-upgrade
apt-get autoremove

When there were no further changes, I was done. The only other change I had to make was to do was
apt-get install gnome-session-flashback so that I could get away from Unity with Dash and back to the Gnome3 Classic interface. gnome-session-flashback is not quite the powerhouse that 14.04's gnome-session-fallback was, but install dconf-tools or dconf-editor, along with gnome-tweak-tool and unity-tweak-tool ocver a lot of ground. Use them, and you get some of that power back.

There are a couple of other tools that I've been exposed to lately, but beyond a certain point, you get lots redundancy and only a few added tweaks. Terminal commands like gsettings and update-alternatives are also extremely valuable and actually take precedence over some of the others. But these last two are just text in a terminal window, and the others are GUI versions and more comfortable for many.

The GUI versions do a bit of explaining and may offer acceptable alternatives for some settings, so are more valuable for beginners. There is no guide as to what to use or do, you just look for web solutions and pick up bits and pieces here and there. These are things I've learned from others and want to share as I learn. May they help you as much as they have helped me.

I tried to open a bug report, but all I know is that Software Updater (a.k.a update-manager) has a problem with controlling the leap from 14.04 to 15.10 in some cases. The second PC had a few problems, such as not rebooting properly and hanging instead, but on power down and power up, behaved rather normally. A few runs with the four commands used on the first PC gave it a clean bill of health. So this is a solution or cure of sorts. like taking a vaccine after falling prey to the illness. But as to cause and future prevention, I've no answers.

And Launchpad was no help. I can tell them there is a problem, but they want me to fix the blame as to package involved. To me, it is just an oversight, something that got missed somewhere. The tools for fixing it are there because I did it. So I am doing the better thing: I am laying it out in the open so everybody gains from this episode. Someone will alert the developer(s) who will recognize the problem and fix it. The fix will likely help repeats of this in the future.

Meanwhile everybody else knows what to expect and can take steps to avoid similar problems on their PCs.The most immediate thing is to make sure that 14.04 is current as to updates and upgrades before you go from 14.04 to 15.10 or later. There was no offer of an intermediate step or series of steps such as going to 14.10 or 15.04 first. Maybe that would have helped in this case. That may have eliminated the reboot hang at the end, where I had to power down and power up to get the same effect manually.

These posts of mine are meant to help. Maybe this one will stand the review it will go through. A lot of people will shortly be moving from 14.04 to 15.10, and you don;t want to be caught up in the crush that is coming, so some will do it early as I did. Now you should be ready, but only if you can find the right help on-line. This should be a part of that help. I hope others see it the same way. It is intended to be instructive because that is what it takes to help people learn. Experts forget that sometimes. Instructions and examples. This post tries to do both.

The posts that follow this on on this thread may do more of the same. Not my posts, but posts from real experts who have real knowledge and understanding of what is going on and what to do. I was just lucky enough to have hit a winning combination. One known command,
sudo apt-get install -fsaved my bacon. Had I known of
sudo dpkg --configure -a I might have gone right to it instead.

Now I know both. And you do to. That is what Linux is all about. No secrets and shared knowledge and work.