View Full Version : Installed Ubuntu but can't boot to it.

February 23rd, 2016, 04:40 PM
I bought a new Windows computer and immediately backed up Windows, changed the partition sizes, installed Ubuntu from a stick onto the big partition, and failed to change the boot order. Now I can boot Ubuntu only off the stick and can't get to the other partition.

After fiddling with the BIOS F2 boot order to no avail (it starts with Windows boot manager no matter what I pick), I figured out how to enable the F12 boot menu to let me boot off the stick, then I tried Boot Repair.

This was the preliminary report:

After that, I ran boot-repair, but it told me there was an error because of Secure Boot:

So I disabled that and tried again:

There's still an error, but I don't know enough to know what. The computer boots to the internal hard drive automatically, which is good, but then I'm looking at Windows Boot Manager again. I've already fiddled with the boot priority order in BIOS with no success, so I don't know what to do next. I also tried to run the Windows command line command recommended, but was told I lack privileges. My password won't let me run cmd as administator, so I don't know what to do here either.

I am not going to use a Windows laptop again, so right now this computer is almost useless to me. Any advice you have would be appreciated.

February 23rd, 2016, 06:36 PM
I saw mention of Acer?

Boot-Repair was supposedly updated to add a mention on Acer systems that Supervisory password & setting "trust" on Ubuntu/grub's efi boot files.

Very latest UEFI/BIOS works, downgrade not required:
Acer E5-573G, downgrade UEFI, supervisor password & trust on Ubuntu efi boot files.
Acer Aspire E15 will not dual boot
Acer Aspire E 15 Downgrade to older UEFI, password & trust (ACPI issues?)
Acer Aspire ES1-512-C39M Details on supervisor password and settings to enable trust on ubuntu entries Also R14 model same fix
One of several with more details:

February 25th, 2016, 10:02 PM
I'm not sure if this is the right place but it seems like a good place:
i just got a new laptop with Win10 on it; i downloaded iso file directly from ubuntu website, ran disc, partitioned and installed but when booting up laptop I'm not getting the option for which OS I want to boot into. I do have an acer aspire F15. I don't know if that matters. I've seen a couple different post about terminal codes to run and programs to download in the Ubuntu OS, but I can't get to that OS. I only seem to be able to get into Windows.
Any tips on getting to my Ubuntu when booting up please?

February 25th, 2016, 10:24 PM
Generally better to start your own thread as boot issues while often similar, also need different commands.
But in your case it does sound identical and solution is in post #2 above.

If not, start a new thread and post link to Summary Report from Boot-Repair.

February 25th, 2016, 11:08 PM
@oldfred: i saw this original post was also an acer so i did piggyback the post. Thank you for the tip towards answer #2. i will give it a shot and if I have any further issues i'll start a new thread. thank you again for the assistance.

March 8th, 2016, 05:43 AM
Hi! Thanks!

I understood from your comments that I should upgrade my BIOS and try again. I did that without especial success. The version I updated to is this one:


My first attempt failed because redoing the BIOS set Secure Boot again and I had to get rid of it. So I tried again, and got another error message. Here is the report:


My expertise level is too low to make too much of it, but I can see it doesn't seem particularly sanguine.

March 8th, 2016, 03:09 PM
I have to change many settings back in old BIOS and even more in UEFI. And new UEFI or BIOS resets everything back to defaults. With BIOS I had to take photos. My new UEFI allows screen shots and lists changes before I save those changes.

Did you enable Supervisory password in UEFI and set trust on Ubuntu/grub's files as posted above?

March 9th, 2016, 02:45 AM
All I did was install this newest BIOS, set the supervisor password, turn off Secure Boot, which Boot Repair asks me to do, unset the supervisor password, and unfreeze the HDD password.

I don't know what UEFI is or how to get to it, and somehow didn't realize there was another step to the process that applied to my computer. I'll try to read through those and let you know how that goes.

Okay, I followed one of the links and now it boots to GRUB automatically. Is there a way to make it boot to Ubuntu instead?

March 9th, 2016, 04:05 PM
When you say boots to grub, to you mean grub menu or an error like grub rescue>

I just change timeout to 3 seconds from normal 10 second to boot Ubuntu. Then I still have time to press a key can choose something else to boot.
In /etc/default/grub

March 10th, 2016, 05:05 AM
The Grub menu. It autoboots to Ubuntu after several seconds, but I have the option to do something else in the interim.

I would like it to just automatically boot to Ubuntu without any such intermission, and to be able to bring back that menu if need be by holding down a button on startup. Is that sort of thing feasible?

March 10th, 2016, 03:31 PM
If you change timeout to zero, then you do not have anytime to press a key.
That was why my compromise is change from 10 sec to 3 sec.

sudo nano /etc/default/grub

And edit timeout as I posted above.

Other grub customization.

How to: Create a Customized GRUB2 Screen that is Maintenance Free.- Cavsfan

March 11th, 2016, 05:48 PM
I see. I did that. Thanks!

If I were to change it to zero, I could get it back if I needed just by changing this number to something positive again?

March 11th, 2016, 09:30 PM
But if system is not working, you cannot get into it to change the 0 back to 3 or 10.
You end up need to chroot from live installer or run Boot-Repair, or Supergrub. I actually have repair flash drives with all those plus a few other tools.
Grub will present menu on abnormal shutdown so you can possibly use recovery mode.