View Full Version : [ubuntu] Boot installation with erased EFI partition

February 22nd, 2016, 01:29 PM
Dear all,
I correctly installed ubuntu 15.10 on a dell xps 9350 (everthing working except DA100 video converters) with legacy mode on and secure boot off.
Later I run boot-repair and the system was not able to boot in any way. So I formatted everything with gparted (erasing all the partitions) and tried to reinstall ubuntu 15.10 from usb but it was unable to install the boot loader.
I think that I erased the EFI partition when I used gparted so may be ubuntu is not able to reinstall correctly the boot loader?
I tried to install Opensuse Leap 42.1 and it installed without problem the boot loader.
There is any solution for this problem? How can I installa again the right boot loader in order to make working ubuntu 15.10?


February 22nd, 2016, 03:12 PM
I'm not clear about your statement in the first sentence above. If you correctly installed Ubuntu, why did you run boot repair?
If you had Legacy mode on then you are not installing EFI and there would be no EFI partition. If you are using EFI, you need Legacy mode off as I understand.
You should have the option to install EFI if that is what you want when you boot the Ubuntu installation medium.

February 22nd, 2016, 04:48 PM
You should be able to install in UEFI boot mode.

But Dell seems to be booting from /EFI/Boot/bootx64.efi which Ubuntu's grub does not create.
Boot-Repair may add it. And I normally suggest that everyone add it as a backup way to boot anyway.

Install Ubuntu 15.10 on Dell XPS 15 2015 9550 with Nvidia 960
Dell XPS 13 9343 Needs /EFI/Boot/Bootx64.efi to boot
Black Screen on Install (15.04 & 15.10) Dell XPS 8900
Dell Xps 15 9550 Ubuntu 15.10 on new Infinity display (i7 6gen 16gbr UHD 4k touch)