PDA

View Full Version : [SOLVED] System Update - Linux 3.19.0-49-generic Black Screen.



FaultedGeologist
February 15th, 2016, 04:16 PM
I let the System Updater run the security update it recommended, then got the BSOD on reboot. After hitting shift during/after BIOS, Grub lets me boot successfully to a GUI using ? Kernel ? Linux 3.19.0-15-generic. It looks like there is a bug report (https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1545510) from my searches.

How do I tell it to boot using 3.19.0-15 every time? Can I clear out the 3.19.0-49? I read what I could from the sticky above. In GRUB it appears I can press 'e' to edit the commands before booting. The thread on that is rather confusing to my N00bness.

Lubuntu 15.04
Raedon 7k 64MB graphics
AMD 64 bit

I've searched and read as much as possible in an attempt.

FaultedGeologist
February 15th, 2016, 04:49 PM
In GRUB, after pressing 'e' for edit, it has options for echo, linux, and initrd. If I change the 3.19.0-49 to 3.19.0-15 in those three lines, would that solve the problem?

I found this thread, which kind of makes sense:
http://askubuntu.com/questions/216398/set-older-kernel-as-default-grub-entry
In this thread, it seems like I would boot to the old kernel from GRUB, then run the sudo commands, edit the file, save, and reboot to see if it took. After running the sudo grub backup command, I would change gedit to leafpad to make this code?:


sudo leafpad /etc/default/grub

Then change the GRUB_DEFAULT="0" to GRUB_DEFAULT="Previous Linux versions>Ubuntu, with Linux 3.19.0-15-generic" and follow the rest of the steps from the above linked AU thread?

Recommendations on which road to travel?

I still get MP BIOS Bug 8254 on booting. In previous research, this has to do with the graphics card.

FaultedGeologist
February 15th, 2016, 07:32 PM
Gotta get this computer project complete so it can move to the computer room and out of the family room... per the linked AU thread above, there are two comments at the bottom about a better or more modern way to accomplish this. See the link preferably, or the copied quotes below.


This is a good solution, but even better is to open a /boot/grub/grub.cfg and there you will see all themanuentry and all the submenus. If you edit them, you can easy set the default ones, even change the Titles of the options in the grub list when restarting a computer.
But then this comment says not to edit them...

It is definitely useful to examine /boot/grub/grub.cfg to determine the exact names to use. But do not change this file as it will be automatically regenerated by update-grub, including on updating packages.


The formatting for GRUB_DEFAULT is slightly outdated (since at least Ubuntu 14.04.2). Running update-grub I encountered a warning: Please don't use old title Previous Linux versions>Ubuntu, with Linux 3.13.0-53-generic for GRUB_DEFAULT, use Advanced options for Ubuntu>Ubuntu, with Linux 3.13.0-53-generic (for versions before 2.00) or gnulinux-advanced-b0ce60c3-184c-453b-af59-419b56a2584f>gnulinux-3.13.0-53-gener*​ic-advanced-b0ce60c3-184c-453b-af59-419b56a2584f (for 2.00 or later)

What to do?

FaultedGeologist
February 15th, 2016, 08:28 PM
SOLVED! Follow the instructions in the above linked AU thread, making sure you read the comments about using

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 3.19.0-15-generic"
#instead of
GRUB_DEFAULT=(a line item as was originally discussed)

It is just taking a while for me to want to edit code without getting confirmation that what I am doing will not screw things up more.

Cheers!