View Full Version : [SOLVED] Cannot install ubuntu dual boot with windows

December 21st, 2015, 08:55 PM
I wanted to install dual boot Ubuntu 14.04.3 with Windows 10 Pro. I made a pen drive USB Bootable stick. Booted it, everything was going well, when I got to one problem: I had 2 partitions, one with 350 GB and another with 100 GB. I don't know why, but it automatically selected the smaller one, with 30 GB files on it, and asked me to shrink it. I shrinked it, everything was going well, but, finally I got a single 450 GB partition, type - lvm. I cannot boot windows too. So I cannot boot without my live USB stick. I have also a Windows 7 installation disk, booted it, and tried to install on the partition, but it couldn't do it, cause the partition was GPT type. I googled it and found some ways to change type, but it required formatting. I cannot access the partition, but I want some files kept. Maybe it's BIOS problem, - UEFI or Legacy type... If I use UEFI, Disk reader and HDD aren't detected. So I cannot boot HDD...
Please help!

December 21st, 2015, 09:27 PM
Your life would have less problematic had you read the link below which explains dual booting windows and Ubuntu in UEFI. Note at the beginning that if you are dual-booting, both systems must be UEFI or both must be MBR.


Although the partition manager used in Ubuntu can resize partitions, when you are resizing a windows partition, you should always use windows tools. Windows 10 it is Disk Management. After doing that you should reboot windows and run chkdsk at least once.

You selected to use LVM installation type which is definitely not the default type. An LVM install overwrites everything and I don't think that is clearly explained in the installer. Stop using the drive.

My understanding is that with windows, if you are using GPT you must also use UEFI which you apparently were not doing. If you can still boot the Ubuntu install flash drive, go to the site below and get the boot repair software and run it and post the output or a link to it here and someone familiar with UEFI should be able to give you some suggestions on possible solutions.


If you have problems/questions in the future, post a question before beginning some actions. Saves a lot of headaches for you.

December 22nd, 2015, 11:33 AM
OK. I have never used GPT. I always used legacy boot. Why did the partition become GPT? I only want to get some data from it. I downloaded boot repair. It has 2 options Recommended Repair, or Create a BootInfo summary. I tried bootinfo summary. It gave me this URL: http://paste.Ubuntu.com/14136275/
What does "stop using drive" means? No chances?
I even don't want my PC to boot, I only want data! Please, help!

Bucky Ball
December 22nd, 2015, 01:54 PM
Welcome. If you only want to retrieve data, boot from the Ubuntu USB, 'Try Ubuntu', save the data to an external device.

If you can't boot without the USB, boot from the Win disk and do a Win repair. The option is there as far as I've read (or is it Win recovery disk?). Once Win is working you can try again with the knowledge of experience and a bit more research.

You are going to need free space to install Ubuntu, no partition. That will happen during install.

December 22nd, 2015, 02:12 PM
I was using Win 10 Pro, but I don't have a disk of it... I downloaded it... Here's a pic:
I want files from the sda3... It was not partitioned before starting ubuntu install... (It isn't installed, it's just live USB). It became partitioned... Help

December 22nd, 2015, 04:22 PM
You either choose LVM or LVM with encryption as drive does not have anything but Ubuntu.

The LVM install is an advanced logical partitioning over the physical partitions. And that is always a full drive install using the selection in the installer. LVM is always a full drive as its advantage is the logical partitions which are easier to change. But if you want other partitions then it does not offer much.

You cannot restore a working system. But because Ubuntu is not large, and it also writes data to random locations on drive, and Windows typically writes data at beginning of drive, not all data is lost.

If lucky testdisk can find older partitions and deeper search finds files. If not you have to use tools like photorec (part of testdisk) to scan drive for anything that looks like a file. Some say that for NTFS, Windows tools may be better.


An alternative Windows data recovery program is Recuva -- and it is free
You could start by using Recuva -- to see what it finds. If it doesn't work, you should then try RecoverMyFiles -- to see what it finds.
NTFS file recovery suggestion by Mark Phelps (not free but works)
For NTFS but may charge to actually get your data, but can run to see if it works better.
For NTFS - GetDataBack often recommended
Caution: getdataback is not the same and is a scam.



December 22nd, 2015, 06:32 PM
I installed TestDisk, analysed the drive, and here's the result:
then tapped Enter:
No what should I do?
Sorry for a stupid question... I am just a tech beginner. And this is first time I posted in a forum...
I don't know how to use TestDisk.
EDIT: If TestDisk can find that partitions, why is Ubuntu installer forced to act stupid and hide them?
EDIT2: May use thing like TeamViewer to help?! I am not English, so it is one more difficulity for me...

December 22nd, 2015, 08:12 PM
Did you try p for list files on second screenshot?
It may take a while, but is best case at possible recovery of files.

December 23rd, 2015, 07:46 AM
I'll give it a try

December 23rd, 2015, 09:41 AM
Did you try p for list files on second screenshot?
It may take a while, but is best case at possible recovery of files.

Thank you! TestDisk recovered my photos! But...
I accessed only second partition. I copied photos, but they're damaged. Some of them are OK, but some are damaged. 0.00B photos? and cannot see em'. Almost 2/3 downloaded to my phone. Then I tried second time, now all photos were 0.00B. Now I have two questions:
1.Why I cannot access the first partition (~350GB)?
2.How can I copy photos from smaller partition without any damage? (If it copied some photos correctly, but second time not, it's not problem of damaged files on partition).
Almost solved...

December 23rd, 2015, 02:35 PM
TestDisk was a solution. I know why photos were damaged. It's problem of space. Now I copy a photo folder to my Pictures, than to my phone, but I cannot delete it from Pictures, so I restart every time I copy a folder. If it will be done correctly, I will mark this thread as Solved!
But I have two questions:
1. Why I cannot access my bigger partition?
2. What did cause the problem?

Bucky Ball
December 23rd, 2015, 02:47 PM
2. What did cause the problem?

Probably this bit:

I had 2 partitions, one with 350 GB and another with 100 GB. I don't know why, but it automatically selected the smaller one, with 30 GB files on it, and asked me to shrink it. I shrinked it.

You shrunk it when you weren't sure what the consequences would be. You were unsure of the process during install. We live and learn. :)

I always encourage new users to make a solid plan with a pen and paper prior to going anywhere near the digital and the process where things can go horribly wrong without one. Perhaps put it down to experience.

With Win installed, the general, and safest procedure, is to choose 'Something Else' at the partitioning section of the Ubuntu install and create the partitions in free space manually, making sure not to go anywhere near the Win partitions or format or resize any of them.

Another tip, just for the heck of it, not that you've done this, but for future reference: Always resize the Win OS partition with Win disk management tools or Win specific software, NOT Gparted in Ubuntu or during Ubuntu install. And vice versa. Always resize the Ubuntu partitions (EXT*) with Linux tools. Win can't do anything useful with EXT* partitions.

Good luck and glad you're having some success. Mark as solved when you have things safely tucked away. This will not close the thread to further discussion, just helps others. Thanks (see first link in my signature).

December 23rd, 2015, 04:38 PM
And... How can I find my Lenovo android phone in TestDisk? (Some folders don't fit in pc availible memory)

December 23rd, 2015, 09:37 PM
Connect an external drive and copy them to that?

December 24th, 2015, 03:04 PM
Ummm... Why does TestDisk copy 0.00B photos and videos? I cannot copy em'!

December 24th, 2015, 03:12 PM
When I try to copy them, some are OK, some are 0.00B, but some aren't present at all... USB Flash is OK, but when I try to create a folder, see image: http://i66.tinypic.com/wl1tmx.pngbut the flash has more than 6 GB left! Please help...

Bucky Ball
December 25th, 2015, 12:26 AM
Perhaps, but how much are you looking to put on it? If more than 6Gb, it won't start the operation.

As far as I'm aware, testdisk retrieves partitions, not individual files, so perhaps you are attempting to retrieve the whole partition.

December 26th, 2015, 03:27 PM
Done it! Thank you all for support!!!