View Full Version : [ubuntu] 14.04.3 LTS Booting to Black Screen - How to actually SEE anything to fix it?

November 12th, 2015, 07:42 PM
I recently installed the Linux Ubuntu 14.04.3 LTS Operating System in my PC but all I saw in the first boot was a black screen. Although I can run the trial version of this same system from my bootable USB stick, I can't run it in my PC. The reason for this is probably my NVidia Graphics Card {and the reason I can run it in the trial version is that it uses the same "graphics environment" it uses when you manually install the OS. This graphics environment stops when the OS is booted from the PC and as the OS can't "see" the NVidia hardware it shows nothing}.

I google-searched it and I found (http://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it) that there is a way you can fix it by pressing the right Shift button (while booting from the PC), going to the GRUB menu and replace some piece of "text" with some other piece of "text". In fact, what google actually shows you - I didn't read all the millions of search results, most of them forum threads, none from Linux's official site - is that you have to replace the words "quiet splash" with the "word" "nomodeset" in order to boot bypassing the graphics card hardware and then download and install the new drivers. As you see, what they're talking about is another old version of the GRUB menu, cause in the new one there's no "quiet splash"...

So, what do I do in THIS new version? Please keep it plain and simple as I do...


November 12th, 2015, 08:11 PM
The image you posted isn't the entire entry. Each entry begins with "menuentry" (not in quotes) and you have to scroll down using the arrow keys on your keyboard to a line that begins with the word linux, use the right arrow key to get to where you want and try the nomodeset option there. Make sure you save it and the key to continue booting should show at the bottom of the screen. This is a one-time fix and the changes are not saved anywhere on the operating system when you reboot.

November 13th, 2015, 08:03 PM
Thanks a lot. My bad I didn't notice. But now I have another problem. Nomodeset mode boots to another dead end. This adding swap thing lasts for a couple of minutes and then goes to black screen.

{There's a difference though. The first black screen, while booting normally, is complete no signal, the monitor goes into energy saving mode. This one doesn't. It's just black. }

Is there a way to install anything on the PC via trial mode? Cause I can see the HDD.

November 18th, 2015, 03:14 PM

Bucky Ball
November 18th, 2015, 03:28 PM
In your grub edit window, did you have the kernel you wanted to change highlighted when you pressed 'e' to edit it? May be a silly question, but need to confirm.

PS: Please attach large screenshots/pics using the paperclip icon in Adv Reply or Go Advanced. :)

November 22nd, 2015, 06:18 AM
What's a kernel? There are four options in the Grub Menu. The first was highlighted by default like in this picture (found it on the internet but it's almost the same):

(I've done memory test too, It says it's ok...)

Also I tried one time to write nomodeset after quiet splash and it didn't even start doing nothing. It just wrote " acpi pcc probe failed" and stuck.

November 23rd, 2015, 07:10 PM
Should I quit and install another version of Ubuntu? The next, which, is is in beta I think, or an older one?

Bucky Ball
November 24th, 2015, 08:37 AM
Don't install 16.04 LTS. That is not released until next April and not a good place to start unless you want a steep learning curve, possible breakage, and daily updates to keep up with changes.

I don't think it's the version that's the problem. Been away from the forum for awhile so I'll have a bit more of a think in a bit. :)

For the moment, choose the second one on the list, the recovery kernel. Does that get you to a list of options after a heap of text whizzing by? If so, continue with normal boot (top selection I think). Anything?

If you can get to the list of recovery options you can drop to a root tty and do some snooping rather than reinstalling just yet. (We consider that a last resort here!). :)

November 26th, 2015, 07:36 AM
Nothing works. Even the arrow keys stop working in recovery mode options.

Can I run boot-repair from trial mode (USB stick) and fix the OS that's in the PC?

Bucky Ball
November 26th, 2015, 07:59 AM
You can create and run Boot Repair from its own Live session (https://help.ubuntu.com/community/Boot-Repair#A1st_option_:_get_a_disk_including_Boot-Repair).

And yes, you can also run it from a Live session (https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu) booted from your install media. Adding the PPA and everything else works fine there. Be advised, though, that anything you install to a live session is wiped so Boot Repair will be gone from the Live install on reboot.

November 26th, 2015, 06:43 PM
Of course it is gone. Every time I boot I install all the programs I need...

The results of boot-repair:

did nothing (and nomodeset mode was adding swap again)

The arrow keys on recovery mode were working, but I couldn't find anything useful there.

December 5th, 2015, 07:36 PM
Reinstalled it without 3rd party content and with internet connection downloading updates. Still nothing. (It shows a purple screen and then a black one)

My system
Intel® Core™2 Duo Processor E6400 (2M Cache, 2.13 GHz, 1066 MHz FSB)
NVidia GeForce 9600GT
Seagate ST3160811AS SATA (HARD DRIVE)

{My cpu is 64bit and I'm running the 32bit ubuntu (I've got only 2GB RAM), but I think that's not the problem. I had been running windows 32bit in this PC too}