View Full Version : Boot problem after upgrade to Ubuntu 15.10

October 21st, 2015, 09:44 PM
Hi All,
After I update to Ubuntu 15.10 with kernel 4.2.0-16-generic, I have boot problem.
When I try to use boot-repair, and I always first got grub boot menu but hang in "Switching clocksource" or directly jump to "No video mode activated, invalid video mode specification 'text'. "booting in blind mode".
My pc has a nvidia gfx 970 card. And it seems I also messup with my grub.

Is there a way to reinstall grub and not reinstall Ubuntu?

I have no problem to boot from livecd. So I wonder how I can fix it?
Currently I can first boot into livecd, and Ctrl+Alt+F1 to switch to terminal and mount the root system.

Thanks for any suggestions. I already stucked on this problem for two days.


October 21st, 2015, 09:47 PM
(Sorry for any bad answers kinda new to Linux (use to be a Windows fan.)) I don't think there is a way. Maybe you can boot from the livecd, and try to reinstall GRUB.
Again sorry for any bad answers.

October 21st, 2015, 11:21 PM
Can you boot with nomodeset?

At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)

Ubuntu Launches Its "Fresh" Proprietary Driver PPA
Instructions are newest driver for newest cards, must load legacy driver if old nVidia card.
Details on why and future incorporation to Ubuntu installer

# Shows standard repository versions
ubuntu-drivers devices
sudo apt-add-repository ppa:graphics-drivers/ppa
# should show newest versions available in addition
ubuntu-drivers devices
sudo apt-get update && sudo apt-get install nvidia-3xx
# I usually use nvidia-3xx-updates, where 3xx is newest available, if older card do not install newest version, check correct legacy version from nVidia.
# While you're at it upgrade libvdpau & nvidia-settings

October 22nd, 2015, 03:06 AM
I did reinstall of nvidia drivers and using boot-repair. Now it did show Grub menu.
But after a long pause (around 3 minutes) in "Switching to clocksource tsc",
Then it shows
findfs: unable to resolve 'LABEL=writable'
[ ] initrd:: mounting /dev/mapper/ubuntu-vg-root
[ ] EXT4-fs (dm-0) couldn't mount as ext3 due to feature incompatiablity
[ ] EXT4-fs (dm-0) couldn't mount as ext2 due to feature incompatiablity
[ ] EXT4-fs (dm-0) mounted filesystem with ordered data mode. Opts....
cannot find 'writable' partition

Then it enters into busybox.

The boot-repair has bootinfo here http://paste.ubuntu.com/12891093

October 22nd, 2015, 04:57 AM
You have a variety of drives all different.
You have gpt partitioned drives & MBR(msdos) partitioned drives.
And you have UEFI and LVM on sdc.

I do not know LVM as that is an advanced logical partitioning which for some has advantages.
Advantages/Disadvantages LVM Post #9

I suggest for long term planning to use gpt partitioning and probably UEFI. I started converting to gpt with every new drive when UEFI first started, but booting in BIOS mode. That made my conversion to UEFI a bit easier as I already had and understood gpt partitioning.

GPT Advantages (older but still valid) see post#2 by srs5694:

UEFI Advantages

October 23rd, 2015, 01:42 AM
I install ubuntu on a samsung ssd, and windows on 1T HDD, another ssd is empty.
I want to restore ubuntu since I don't want to reinstall all stuff I installed on the disk.

I really hope someone can help me out.


October 23rd, 2015, 04:47 AM
If you turn on UEFI and turn off CSM/Legacy/BIOS can you boot ubuntu entry in UEFI?
And can you turn off UEFI and turn on CSM and boot Windows from drive that is sdb. It shows Vista? Is that correct?

The grub installed to the MBR of sdc, should not now work for BIOS boot, as grub has been reinstalled to boot in UEFI mode from ESP on sdc.

October 23rd, 2015, 05:13 AM
If I set to legacy boot, I can boot into window 10.
If I set to UEFI boot, it will show grub menu, I can only boot into busybox.

I can use livecd to boot into Ubuntu and chroot to mound LVM partition. But I don't know why uefi boot cannot boot into ubuntu.


October 23rd, 2015, 05:21 AM
Have you tried recovery mode, or one of the older kernels?

Do not know enough about LVM specific issues to really help.

October 24th, 2015, 03:12 AM
Solved. I use live cd and choose to install Ubuntu.
When select install partition stage, ubuntu will show the partitions already created. Don't Format

Chose mount point for each partition, and then select continue. The grub installer will be reinstalled correctly.
After it, it still have some issues, but at least I can boot into text mode and fix all other issues.