View Full Version : 14.04.4 LTS Installation Freezes at Splash Screen on Acer X452M

September 3rd, 2015, 03:37 PM
My daughter (14) has asked me to convert her Acer X452M across to Ubuntu (as we have it on all our other machines and she's hating Windows 10) for I created a 14.04.3 LTS USB and attempted to 'Try Ubuntu without installing', however it repeatedly freezes at the splash screen (ie the Purple screen where the dots change from white - it does for while then hangs).

Having checked a couple of forums, I have updated the BIOS to the latest version, but this has made no difference.

I attempted the boot in verbose mode, and have discovered the system freezes after the comments:

* Starting bluetooth daemon
* Stopping flush early job output to logs

I've been successful in installing Ubuntu flavours on 4 other machines (2 x Complete Ubuntu Installation, 1 x Windows/Ubuntu Dual Boot and 1 x Ubuntu Studio) and haven't had any problems.

Any assistance would be greatly appreciated.

Bucky Ball
September 3rd, 2015, 04:31 PM
Welcome. Here's to more 14 year olds making that request. Have you tried the options at boot? When it gets to that purple screen and before it freezes does it have the little icon down the bottom of the screen? Hit any key (I think but experiment) and it should take you to the 'Try Ubuntu' screen. There, hit F6 and try 'nomodeset' option from the pop-up. Continue on with 'Try Ubuntu' (not install). Any luck? If not, repeat and try some of the other options.

You don't have a bluetooth dongle plugged in by any chance?

September 3rd, 2015, 04:47 PM
Thanks for the rapid reply

Pressing various keys at the Ubuntu splash (where the dots change white to orange and back) made no difference - but when I tried F6, I saw what I was getting with verbose mode [by pressing Esc, I'm assuming that F6 is an alternative way of doing this] and one occasion got the unusual comment:

soft lockup - CPU#0 stuck for 22s

But trying again, it either hangs at the point stated above or at:

* Starting system logging daemon

And no, no dongles attached to the machine other than the bootable USB.

Bucky Ball
September 3rd, 2015, 06:35 PM
I gather this (http://askubuntu.com/questions/668576/cannot-install-ubuntu-14-04-on-asus-x453m) is the same computer and same issue? The responder there seems to have solved the 'starting system logging daemon' issue there. Does their solution have any relevance to your situation?

September 4th, 2015, 09:38 AM
It was indeed - and I tried it and it worked beautifully - thanks so much! My daughter is going to be delighted when she gets home to be back to Ubuntu.

A question for my own education, why would the OS selection in the BIOS make a difference?

Bucky Ball
September 4th, 2015, 09:41 AM
A question for my own education, why would the OS selection in the BIOS make a difference?

I have absolutely no idea. :) Wouldn't have thought of that myself, and didn't.

Please see the first link in my thread to mark as solved and help others. Good luck and hope your daughter's happy with the outcome. :D

September 5th, 2015, 06:48 AM
Because of a secure boot option in the bios to look for a windows type digitally signed OS signature... That would be my offhand guess without knowing anything about their laptop...

On the new HP's I'm also seeing new BIOS options to select for standard or legacy BIOS, which would mean that those can switch between Non-EFI BIOS or EFI BIOS modes.

But my curiosity is if it is really an Acer or an ASUS? I see an ASUS X452 model listed, but with Acer for that model number draws a blank on their support site. That model in ASUS has AMD Radeon® HD 8530M GPU... Just FYI.