View Full Version : [xubuntu] Booting from 15.04 installation media hangs when booting with UEFI

August 28th, 2015, 02:20 AM
I want to dual boot my laptop with Windows 10 and Linux. I'm attempting to install Xubuntu 15.04 x64 but when I boot from the installation media it hangs on starting version 219 then eventually my caps lock LED starts flashing and it reboots... rinse and repeat.

I've tried booting from CD and USB, both hang in the same spot. I've tried disabling secure boot and fast boot and it still hangs. The only thing I can get to work is if I enable UEFI with CSM (Compatibility Support Module), then the installation media will boot and I can start the install.

I would prefer to not have CSM enabled since Xubuntu 15.04 claims to work with EFI and I would like to use EFI only (actually I have to use only EFI because Windows 10 was installed as EFI). Anyone know what the deal is?

The laptops specs are as follows in case that might have something to do with it:

Intel i7 5th gen processor
64 gigs system ram
2x Nvidia GeForce 980M with 8 gigs each
Mostly SSDs configured in RAID 0 (Stripe)
Secure Boot Enabled
Fast Boot Disabled
UEFI Enabled
Windows 10 installed (was installed with UEFI enabled)
Windows 10 Fast Startup is disabled
Windows Boot Manager has lowest priority on boot


I tried the same things as above but with Fedora 22 and it produced the same results.

August 28th, 2015, 05:14 AM
Are the 980M in the same Maxwell family as the 980 cards?

Maxwell versions need new kernels, support software & video drivers. But 15.04 should be new enough, but you may need nomodeset on grub menu when you boot installer.
At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)

The GTX 970/980 Maxwell GPUs Light Up With Nouveau On Linux 3.19
NVIDIA GeForce GTX 970/980: Windows vs. Ubuntu Linux Performance 2015 note versions ppas used to update

Ubuntu Launches Its "Fresh" Proprietary Driver PPA
Instructions are newest driver for newest cards, must load legacy driver if old nVidia card.
Details on why and future incorporation to Ubuntu installer
sudo apt-add-repository ppa:graphics-drivers/ppa.

August 28th, 2015, 05:27 AM
nomodeset was the problem, thank you so much. I replaced quiet splash with nomodeset and it now boots into the installation.

August 28th, 2015, 05:35 AM
So it booted into the installation and I was able to connect to my wireless network and start installation but right after I click next after choosing to install updates while installing and to install 3rd party software, the laptop hangs and the caps lock flashes again.

August 28th, 2015, 05:50 AM
This is the error that is happening now. It seems to be sporadic and doesn't happen in the same place every time.

kernel panic - not syncing: timeout synchronizing machine check over cpus
shutting down cpus with nmi

August 28th, 2015, 03:58 PM
Did you add ppa & install nVidia driver?

this thread is on 750 Maxwell, but all Maxwell are the same.

August 28th, 2015, 05:57 PM
How would I go about doing that when this is on installation media? It's not an installed instance so any changes aren't persisted so if a reboot is required then I'm back to where I was before.

August 28th, 2015, 07:32 PM
I thought it was after you installed.

If installer then you may need other boot parameters in addition to nomodeset.
What brand/model system.

Does it boot with using internal Intel video chip? That would not need nomodeset but may need other settings. That would isolate video as issue or something else.

Skylake needs this boot parameter: i915.preliminary_hw_support=1
Xubuntu 14.04 - GRUB2 nomodeset brings wrong screen resolution - Acer TravelMate 4740 with Intel HD Graphics
kernel 3.19 which is implemented with all needed intel graphic stuff

Mesa 10.5 vs. 10.7 Git, Linux 4.2 Kernel For Intel Iris Graphics 5100
Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09) Dell 17R

August 28th, 2015, 09:00 PM
It's an MSI GT80 Titan laptop. It supposedly has an onboard intel video card but I've not seen a way to switch to that in the BIOS and it comes with a button to switch between the Nvidia cards and the onboard card but the button doesn't seem to do anything. I press it and the LED stays on; it's supposed to turn off when not using the Nvidia cards.

August 28th, 2015, 09:26 PM
Both the Optimus dual video and RAID 0 complicate the install.
I do not know details of either.

This showed dri_prime=1 parameter may be required?
older info:
Dual graphics nVidia GT840M
Dual graphics install nVidia prime and newer nVidia driver

With RAID, grub may not correctly install, and you have to use Boot-Repair or manually install it. With UEFI it may work?

August 29th, 2015, 04:46 AM
I completely removed the RAID and nVidia cards out of the equation. It's not optimus it's an actual on off switch so when the nVidia cards are off, they're actually not there as far as the system is concerned.

So, without RAID 0 and without the nVidia cards it boots into the desktop environment without the use of nomodeset but still gives the kernel panic.

August 29th, 2015, 01:38 PM
In addition to parameters suggested before, these may be required with Intel or laptops.
Use each of these instead of nomodeset. And then maybe add one of the others if required.

# Usually Intel works with one of these:
video=1280x1024-24@60 # but change to your monitor size not 1280x1024
video=VGA-1:1280x1024-24@60 # but change to your monitor size
# Other settings in addition to above for other hardware related issues

August 30th, 2015, 12:23 AM
I tried a bunch of different combinations of what you suggested and nothing works. All of them give the same kernel panic except i195.i915_enable_rc6=1, that one gave a kernel panic with stack trace but I couldn't capture what it said.

I'm thinking the issue is either the Intel Wireless AC 7260 w/bluetooth or maybe the Intel Rapid Storage RAID?

August 30th, 2015, 04:39 AM
If you have turned off the RAID, you should have drives in AHCI mode.
The Intel SRT is usually seen as RAID and used to have major install issues, but recent versions seemed to let Ubuntu install, but grub saw RAID and did not install correctly. Manual work around then required.

I thought newer Intel used this:
Newest used this:
And not yet fully supported Skylake used this: