View Full Version : Ubuntu won't install. Absolute Newbie.

April 14th, 2015, 11:32 PM
Hey guys,

I'm an absolute newbie with this and a computer layman. I appreciate any help I can get.

I have a Dell XPS 15Z that I am trying to install Ubuntu 14.04 on. It was previously running Windows 7, however, the hard drive failed a couple days ago. I bought a used hard drive from a from a local repair shop and am attempting to install Ubuntu on it. I really have extremely little experience with fixing computers so please excuse me...

I created a bootable USB and DVD, however, neither work. Here's what happens:


-The computer boots up to the menu and I can select any of the options.
-If I select Install Ubuntu it will start the Ubuntu install very slowly and will freeze up before I can actually do the install. One time I got though a couple of the preference screens but it had some errors such as "error opening /dev/sdb" and then it freezes.
- If I select Try Ubuntu Before Installing it loads up very slowly and is basically unusable. If I try to use the install Icon it won't do anything.


The computer boots up and loads the DVD. Ubuntu does not load and I get what looks like a "dos screen"(black screen with text going across it quickly) and it ends with an error saying "cannot find medium live file system" Then it does nothing.

I've been at it for hours trying different USB's and different DVDs with no luck. I also reformatted the hard drive to NTFS with no luck.

Where do I go from here?

Perhaps the computer has more issues than just a failed hard drive?

Again, appreciate any direction someone can point me in. It would be much better if I can get this computer working so I can get my project done on budget....

April 14th, 2015, 11:56 PM
andrew214; Hi ! Welcome to the forum .

First things 1st; Did you verify the .iso file ?

Next; Did you verify the burn(s) ?

With known good medium in hand, we can proceed.

all in the process

April 15th, 2015, 12:48 AM
According to this link that machine has hybrid graphics, also called Nvidia Optimus technology. It has both an Intel and an Nvidia graphic adapter. It could be the installer is getting confused about which graphic adapter to use.


Is it possible to set the machine to use either the Intel adapter or the Nvidia adapter for the purpose of installing? The installer uses an open source video driver which will work with either Intel or Nvidia video adapters but I have no idea how well it works when both adapters are available.

The Nvidia drivers that come with Ubuntu 14.04 and later versions do work with Hybrid graphics but they do not do automatic switching of adapters. That has to be done through the Nvidia Xserver Settings utility that will install along with the Nvidia video driver. You can search for it in the Dash once Ubuntu is installed. Click the Ubuntu icon at the top of the Launcher (side panel) and search for Nvidia.

Or you can install Prime Indicator which will put an app indicator in the top panel and you can use that for switching video adapters.



April 15th, 2015, 01:45 AM

Thanks very much for the replies.


I have redownloaded Ubuntu and tried it again following your steps as indicated. As far as I can tell everything should be good to go. However, it still is not working. I took some pictures with my phone. This is what happens first:

Then the screen goes black for about 2 min and then this shows up:

That's all it does. It does not let me type anything.


It does indeed have an extra graphics card. I searched through BIOS and could not find a way to shut any of them off. I did a google search and it seems like many others have been wanting to do the same thing but cannot find a way to do it either. (without windows being installed that is). That could very well be the issue...

April 15th, 2015, 04:33 AM
Your drive is showing frozen as the status.
Does UEFI/BIOS show drive correctly?

And sr0 is your DVD, and it then shows an error. It should boot even without a hard drive.
So seems DVD burn was not correct.

Did/does this system have Intel SRT or similar? The Intel settings for that can cause problems.
Make sure UEFI has hard drive settings changed from Intel SRT to AHCI.

Then try flash drive again.

April 15th, 2015, 04:49 AM

Funny you say the DVD is frozen... I was actually just wondering if the dvd drive still works in it. I honestly can't remember the last time I tried to use it. Also, yes it is set to AHCI.


I just successfully installed 12.4.5 32 bit via USB. Everything seems to be working so I am now attempting to upgrade it to 14.04 32bit. I will update once it completes.

Perhaps it was the 64 bit version causing issues? I think it should work with 64 though, as the windows 7 was 64 bit. It has an i7-2630m processor and 8 GB of ram. If possible I would like to utilize the 64 bit version...

April 15th, 2015, 05:06 AM
Not sure why 64 bit should not work, unless original download of ISO had an error?
The 32 bit version will only install in BIOS boot mode.

With and i7, you should use 64 bit.
Is system only BIOS or UEFI and CSM.
CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode

Frozen was on ata2 which I guess is hard drive.
But sr0 is DVD.

Post this from either live installer or your 32 bit install:
sudo parted -l

April 15th, 2015, 02:33 PM
Ok, so, here is a series of events that took place:

-12.4.5 32 bit installed fine with a USB.
-After testing it out for a few min I decided to try to upgrade to 14.04 32 bit.
- 14.04 installed but would not work. It would only get me to a "grub screen" where it would ask me to select Ubuntu or recovery mode. If i tried either it would go to a black screen for a minute or two and then restart the computer.
- I formatted the hard drive.
- I tried to install 12.4.5 64 bit with USB.
- It failed to install and froze up the same way the 14.04 64 bit would. It always freezes up when I try to use the keyboard (The first time you use the keyboard is to connect to wifi).
- I then installed 14.04 32 bit with USB and it installed perfectly. I am currently using this version.

When I type you command in to the terminal I get this:

Also, while I was typing this up the screen went black (I thought it was just a screen saver) and I got this error:

Regarding the BIOS vs UEFI.. Sorry, that's a bit over my head. I tried to do a google search but didn't come up with anything I understood.

Thanks very much for your help.

April 15th, 2015, 03:09 PM
It's not possible to read the error message in the image. Could you post what comes after "Sorry, Ubuntu 14.04 has ...??

April 15th, 2015, 03:30 PM
It's not possible to read the error message in the image. Could you post what comes after "Sorry, Ubuntu 14.04 has ...??

Sorry, it said "Ubuntu 14.04 has experienced an internal error".

The first line in the text box that's hard to read says:
"Executable Path

For what it's worth, I've been using the computer for about 1 hour now without issue.

April 15th, 2015, 03:39 PM
I would think the issue is with video drivers in the 64 bit, but do not know for sure.

Most users with newer Dell systems have installed in UEFI mode.
For lots of info and many links to too much info see link in my signature below.

Have you updated your UEFI/BIOS to the latest version from Dell?

Dell issues are common across models.
Dell Inspiron 3521
Ubuntu on the Precision M3800 or XPS15 Nov 2013
Dell 14z & 17r with Intel SRT
Dell 17R Brightness