View Full Version : [ubuntu] LTS 14.04.1 Grub only shows memory test

April 9th, 2015, 01:55 PM

Hope someone can help and show how easy it is to fix my issue:

Replaced the power supply in my desktop computer - probably totally unrelated (but it is a change in the config) - on reboot my Grub2 only shows Memory test like this post:

I have downloaded the Boot-Repair-Disk and started the auto fix, but it keeps running on "Purge Kernels then reinstall last kernel (ins)" section - have tried leave it over night just in case "several minutes" could be longer :))

In a terminal I can see both my Grub (sda1) and data (sda5) so disk is good.
Only installed OS is Ubuntu 14.04.1 LTS, using the entire disk.
Config can be seen at: http://paste.ubuntu.com/10781936/

In my desperation I tried following this post http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd reinstalling Grub, and it works, now I boot to a grub prompt.

It must be possible to either program the grub to boot from the disk OR reinstall Ubuntu - but in case of reinstall, what about my programs, I have Backup Central running on this machine.

Thanx in advance


Christian Sonder

April 9th, 2015, 02:18 PM
in case of a single Os installation, the menu should directly boot; only multi installed OSs are detailed into the grub menu.
from an usb iso boot you still can reinstall it: sudo grub-install /dev/sda and then reboot

April 10th, 2015, 11:21 AM

Tried that from Boot-Repair-Disk, launch a terminal and use "sudo grub-install --root-directory=/mnt/boot-sav/mapper/Server-root /dev/sda" and it returns OK.
Booting send me to grub prompt. Using ls command at grub prompt, to try to use this post: https://www.linux.com/learn/tutorials/776643-how-to-rescue-a-non-booting-grub-2-on-linux/ shows that my root is inside lvm (lvm-Server-root) hence I cannot read it from grub.

Any suggestions - reading about the bug re. re-install Ubuntu which might format my harddrive, dose not seem like a good path :))

UPDATE: Found this post: https://help.ubuntu.com/community/Grub2/Troubleshooting#Search_.26_Set
Using ls / shows the contents of my hardrive, BUT I cannot see initrd, vmlinuz, linux* or any other kernel files

UPDATE2: Tried geting Live CD (14.04.2 LTS) it says "No OS installed"



April 13th, 2015, 09:04 PM
Closed thread because I have started reinstall Ubuntu and hope for getting LVM online, reinstall applications and resume services