View Full Version : [ubuntu] How to recover from a mistake

February 20th, 2015, 04:00 AM
Hi ,

I have installed UBUNTU 14.04 LTS and updated all the files as asked by the OS, next I went to AMD's website and downloaded its v14.12 Proprietary drivers. I to used the amd-driver-installer-14.501.1003-x86.x86_64.run file and it made my system freeze (after executing very slowly for almost 45 minutes). I had to reboot it. Now I've installed Steam and try to do a check for video driver update and it says 'Steam is unable to preform video driver detection on your system'.

How do I reverse the changes that might have happened while installing via the 'amd-driver-installer-14.501.1003-x86.x86_64.run' command.

How do I do the following?

The display driver requires POSIX shared memory to be enabled on the system.

Kernal Sources package is no longer required if Kernel Header package is installed.

32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

Also How do I install the proprietary drivers properly?

If you need any more info please mention so.

Thanks in advance.

P.S:- I am using AMD Athlon II X2 260, Asus M4N68T-M LE-V2, 4GB DDRIII Gskill 1333MHz & Asus HD7750-1GD5-V2. (WINE IS NOT INSTALLED)

February 20th, 2015, 04:03 AM
Did you by chance backup any of the files you modified prior to modifying them?

February 20th, 2015, 04:17 AM
I did not backup anything , how to do so?

February 20th, 2015, 04:24 AM
Did you just run the installer without arguments, or did you run it in buildpkg mode?

It's been a while since I messed with the AMD/ATI drivers, but I seem to remember the installer has an unistall option - have you tried running

./amd-driver-installer-14.501.1003-x86.x86_64.run --help

February 20th, 2015, 04:27 AM
I just ran the 'amd-driver-installer-14.501.1003-x86.x86_64.run' file, I will run the command you gave.

I have installed my /home on a bigger partition not near the root so when I run your command,

i get amd-driver-installer-14.501.1003-x86.x86_64.run: command not found

I just ran the 'amd-driver-installer-14.501.1003-x86.x86_64.run' file by double clicking on it, I will run the command you gave.

February 20th, 2015, 04:43 AM
To run it with the --help option, you will need to use a terminal and navigate to the location of the file

February 20th, 2015, 04:53 AM
how to locate the file ? I am not completely familiar with linux filesystem

Just help me do the
the following :

Enable POSIX shared memory.

Ensure that Kernel Header package is installed.