View Full Version : [ubuntu_studio] No Grub after installing ubuntu studio; Windows 7 doomed

January 27th, 2015, 08:00 PM
Hello everyone!

I am new to ubuntu(or linux) & i need urgent help!!

I did a complete formatting & re-partitioning of my hard disk.

After that I installed windows 7 (64 bit) first & then ubuntu studio (64 bit). But after installing ubuntu studio, it did'nt bother to install grub or any software to allow me to enter windows 7.

I used the boot repair software for the problem. Boot repair installed a grub menu but there is no option for windows.

Also, it gave me a URL to indicate my boot repair stats or something!

Please help me add the windows 7 option to the menu. My work is stuck since many days!!

Thanks & Regards,

prasad :)

January 27th, 2015, 08:08 PM
prasad13; Hi ! Welcome to the forum .

Try this:
boot to a terminal in 'buntu and execute terminal command:

sudo update-grub

I do expect the tool 30_os-prober to find Windows boot code and the system to then chainload it onto grub's boot menu .
Reboot to see the effect.

ain't 'buntu wonderful

January 27th, 2015, 08:18 PM
Tried it...didn't work!

January 27th, 2015, 08:35 PM
prasad13; Welp;

Tried it...didn't work!
Does not tell us anything and does not help in finding the cause.
What exactly was the result of "update-grub" ?
What is the exact error messages given ?

Maybe what is required is to install Windows Boot code from Windows (??) Then (RE-)install ubuntu's grub ??

Might be best to show us what we are working with :

sudo fdisk -lu
sudo parted -l
df -h

These will give a more directed response .

bios hands off where ?

January 27th, 2015, 08:50 PM
i didn't take note of errors during update-grub...but i think it was successful. I ran the command again & the output is like this:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-44-lowlatency
Found initrd image: /boot/initrd.img-3.13.0-44-lowlatency
Found linux image: /boot/vmlinuz-3.13.0-44-lowlatency
Found initrd image: /boot/initrd.img-3.13.0-44-lowlatency
Found linux image: /boot/vmlinuz-3.13.0-32-lowlatency
Found initrd image: /boot/initrd.img-3.13.0-32-lowlatency
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Also, i have installed ubuntu on 200 gb partition, 8 gb partition was given for swap, & two 134 gb volumes were for windows

sudo fdisk -lu output:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xf71899d8

Device Boot Start End Blocks Id System
/dev/sda1 * 540291072 976771071 218240000 83 Linux
/dev/sda2 206848 262146047 130969600 7 HPFS/NTFS/exFAT
/dev/sda3 262146048 524290047 131072000 7 HPFS/NTFS/exFAT
/dev/sda4 524290048 540291071 8000512 82 Linux swap / Solaris

Partition table entries are not in disk order

sudo parted -l output:
Model: ATA WDC WD5000BPVT-7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number Start End Size Type File system Flags
2 106MB 134GB 134GB primary ntfs
3 134GB 268GB 134GB primary ntfs
4 268GB 277GB 8193MB primary
1 277GB 500GB 223GB primary ext4 boot

df -h output:
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 205G 28G 167G 15% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 1.9G 4.0K 1.9G 1% /dev
tmpfs 387M 1.2M 385M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.9G 84K 1.9G 1% /run/shm
none 100M 32K 100M 1% /run/user
/home/prasad/.Private 205G 28G 167G 15% /home/prasad

January 27th, 2015, 09:02 PM
prasad13; Humm ..

Will take someone with greater Window's fu than I posses; but, I think Windows wants to be in that 1st partition where you presently have 'buntu installed.

/dev/sda1 * 540291072 976771071 218240000 83 Linux
/dev/sda1 205G 28G 167G 15% /

Else Window's boot code will not install correctly.

I could be in error

Windows is not in my interest

January 27th, 2015, 09:05 PM
Oh God :(
Let's see if someone can come up with a solution!
Anyways, Thanks a lot for trying!! :)

January 27th, 2015, 09:29 PM
prasad13; Hey !

The knowledge base here is astounding. There are a number of peeps here with that knowledge.
Hang loose and let's see who responds .

If I knew everything

I would not be me

January 27th, 2015, 10:04 PM
Your win7 partition does not show the needed boot file "bootmgr". I do not know how to fix but a web search for 'missing win7 bootmgr' likely will have some info.

January 27th, 2015, 10:46 PM
Windows 7 installs most often have a separate boot partition that has bootmgr & BCD. That is not required, but it looks like you erased the Windows boot partition. You can move boot flag to sda2. Windows has to have boot flag to know which partition to boot, repair or install into. Grub/Ubuntu does not use boot flag. You can use gparted to move boot flag or your Windows repairCD/flash to make active sda2.

Then you need a Windows repairCD or flash drive and run the standard set of Windows repairs. You cannot add bootmgr nor BCD from any Linux repair tools.

After Windows repairs it will probable also add the Windows boot loader to the MBR. You then can use Boot-Repair to add grub & update grub menu to show Windows.

Windows 7 repair USB, Also Vista if service pack installed


January 27th, 2015, 11:06 PM
@ prasad13;

See oldfred's directive .

@oldfred, so I stand corrected that it is not imperative that Windows occupy that 1st partition ?
(just so I do not pass invalid advise in the future ) .

one of those times I just do not know

January 28th, 2015, 04:35 AM
Generally, windows 'boot' files need to be on a primary partition in order to install properly. Having a missing bootmgr file and having the Ubuntu partition marked as active rather than the windows partition are likely the major problems here.

January 28th, 2015, 07:40 PM
Had to reinstall win7 and run boot repair tool.
the grub has bot ubuntu and windows now!
I had deleted the boot partition windows created before....because i can have max 4 partitions & the extra windows partition was unwanted(for me :p)
so i had deleted that partition...anyways, everythings working now.
Thanks a lot guys! :)

January 28th, 2015, 10:13 PM
Windows in BIOS/MBR boot mode only boots from a primary partition formatted NTFS with the boot flag or active partition. It normally is first as most systems are pre-installed. But can be any sda1 thru sda4. But often does not correctly see Linux in the extended partition if installed after the extended and causes issues. So if using an extended partition best to have it after Windows.