View Full Version : Installed Ubuntu using "Something Else," I now can only use ubuntu recovery mode

December 7th, 2014, 02:56 AM
Ok, so I installed ubuntu this morning, and I selected the "Something Else" option because it didn't give me an option to install alongside windows. I followed a guide and it worked, but it just booted right into ubuntu. I used boot repair and the second time went flawlessly. I installed a script that allowed me to use the backlight on my keyboard, and installed some new themes. Now whenever I logon I get this black screen unless I go into recovery mode and click "resume," and it works perfectly fine.
I had also installed an nvidia driver, I think it was nvidia-current.

also, I created a bootinfo summary just now. I also have the one from when I first did boot-repair.
From just now: http://paste.ubuntu.com/9404769/
From earlier: http://paste.ubuntu.com/9402854/

I also had many issues with installing linux, I first tried with Elementary OS, and it gave me the option for installing alongside my "other operating systems", but when I booted, it always went into windows, and I could never get it to boot into eOS. After this I tried ubuntu, and followed a guide for using the "something else" feature, creating the / mount point, as well as /home, and swap space.

PC Specs:
PCPartPicker part list (http://pcpartpicker.com/p/WG63WZ) / Price breakdown by merchant (http://pcpartpicker.com/p/WG63WZ/by_merchant/)

CPU: Intel Core i7-4790 3.6GHz Quad-Core Processor (http://pcpartpicker.com/part/intel-cpu-bx80646i74790) ($296.97 @ OutletPC)
Motherboard: Gigabyte GA-H97-GAMING 3 ATX LGA1150 Motherboard (http://pcpartpicker.com/part/gigabyte-motherboard-gah97gaming3) ($97.99 @ Amazon)
Memory: G.Skill Ripjaws X Series 8GB (1 x 8GB) DDR3-1333 Memory (http://pcpartpicker.com/part/gskill-memory-f310666cl9s8gbxl) ($78.99 @ Newegg)
Storage: Western Digital Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive (http://pcpartpicker.com/part/western-digital-internal-hard-drive-wd10ezex) ($52.89 @ OutletPC)
Video Card: MSI GeForce GTX 760 2GB TWIN FROZR Video Card (http://pcpartpicker.com/part/msi-video-card-n760tf2gd5oc) ($203.98 @ SuperBiiz)
Case: Thermaltake VL800P1W2N (Black/Red) ATX Mid Tower Case (http://pcpartpicker.com/part/thermaltake-case-vl800p1w2n) ($49.99 @ Mwave)
Power Supply: Corsair CX 500W 80+ Bronze Certified Semi-Modular ATX Power Supply (http://pcpartpicker.com/part/corsair-power-supply-cx500m) ($54.99 @ Newegg)
Wireless Network Adapter: Rosewill RNX-N250PC2 802.11b/g/n PCI Wi-Fi Adapter (http://pcpartpicker.com/part/rosewill-wireless-network-card-rnxn250pc2) ($16.14 @ Amazon)
Keyboard: Cooler Master CM Storm Devastator Gaming Bundle Wired Gaming Keyboard w/Optical Mouse (http://pcpartpicker.com/part/cooler-master-keyboard-sgb3010kkmf1us) ($28.99 @ NCIX US)
Total: $880.93
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2014-12-06 20:55 EST-0500

December 7th, 2014, 04:57 AM
I had also installed an nvidia driver, I think it was nvidia-current.

How did you install the driver and from where?

December 7th, 2014, 05:43 AM
Also which video output are you using. With a motherboard like that you do not have dual video that you can switch, just which port you plug monitor into. If motherboard you are using Intel and nvidia driver may conflict. Or if nVidia card then you need nVidia driver.

Script shows this:
Kernel driver in use: nouveau

So nVidia driver not correctly installed.
You have both systems install in BIOS boot mode on a MBR(msdos) partitioned drive.
Most now use UEFI on gpt partitioned drive, but Windows 7 default is normally BIOS/MBR. You have to convert its installer to flash drive and do some updates to make it work for UEFI.

turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards.
Gigabyte Z97-HD3 Intel Z97 Motherboard
GIGABYTE GA-970A-DS3 motherboard not working with 64 bit kernel - IOMMU

You also moved boot flag from sda1 to sda2. That is ok, but the reason Windows creates the sda1 boot partition is for booting and it normally had boot flag. It also has the repair console (f8) and I then do not think that will work booting from sda2. But better to have a Windows repair CD or flash drive anyway.