PDA

View Full Version : [SOLVED] 14.04 upgrade from working 13.04 with Nvidia Quadro 4000 video now broken



Kenley_Fritts
November 25th, 2014, 01:42 AM
So, I had a working 13.04 environment and after upgrading to 14.04, I was unable to login to the desktop and then I tried many different suggested fixes. The last fix I tried was using the downgrade one here: https://help.ubuntu.com/community/DowngradeHowto

Long story short, now I cannot install anything because of the errors below. The main problem is I cannot reinstall xserver-xorg because I think it's because there are no nvidia-304 drivers (where it used work). The current state is much better (or worse) that before where I had so many broken dependencies, but after running he downgrade, the list has become shortened to the output below. Any help or suggestions before I basically wipe it clean and re-install, will be appreciated.

root@kenley-HP-Z600-Workstation:/# lspci |grep VGA
0f:00.0 VGA compatible controller: NVIDIA Corporation GF100GL [Quadro 4000] (rev a3)
root@kenley-HP-Z600-Workstation:/# lshw-gtk
The program 'lshw-gtk' is currently not installed. You can install it by typing:
apt-get install lshw-gtk
root@kenley-HP-Z600-Workstation:/# apt-get install lshw-gtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable or
xorg-video-abi-14 but it is not installable
nvidia-331 : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable or
xorg-video-abi-14 but it is not installable
thunderbird-gnome-support : Depends: libebook-1.2-12 but it is not installable
xserver-xorg-input-evdev : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-mouse : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-synaptics : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-vmmouse : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-wacom : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-video-fbdev : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-openchrome : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-qxl : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-savage : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-sis : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-vmware : Depends: xorg-video-abi-11 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@kenley-HP-Z600-Workstation:/#
root@kenley-HP-Z600-Workstation:/# dpkg --get-selections > installed-software
root@kenley-HP-Z600-Workstation:/# view installed-software
root@kenley-HP-Z600-Workstation:/# dpkg --set-selections < installed-software
root@kenley-HP-Z600-Workstation:/# apt-get deselect-upgrade
E: Invalid operation deselect-upgrade
root@kenley-HP-Z600-Workstation:/# apt-get dselect-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable or
xorg-video-abi-14 but it is not installable
nvidia-331 : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable or
xorg-video-abi-14 but it is not installable
thunderbird-gnome-support : Depends: libebook-1.2-12 but it is not installable
xserver-xorg-input-evdev : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-mouse : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-synaptics : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-vmmouse : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-input-wacom : Depends: xorg-input-abi-16 but it is not installable
xserver-xorg-video-fbdev : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-openchrome : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-qxl : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-savage : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-sis : Depends: xorg-video-abi-11 but it is not installable
xserver-xorg-video-vmware : Depends: xorg-video-abi-11 but it is not installable
E: Unmet dependencies. Try using -f.
root@kenley-HP-Z600-Workstation:/# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
bbswitch-dkms libcuda1-331 libmessaging-menu0 libspice-server1 libxatracker2
nvidia-331 nvidia-libopencl1-331 nvidia-opencl-icd-331 nvidia-prime
thunderbird thunderbird-gnome-support xserver-xorg-input-evdev
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-fbdev
xserver-xorg-video-openchrome xserver-xorg-video-qxl
xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-vmware
Suggested packages:
bumblebee nvidia-331-uvm ttf-lyx gpointing-device-settings touchfreeze
The following packages will be REMOVED:
nvidia-304
The following NEW packages will be installed:
bbswitch-dkms libcuda1-331 libmessaging-menu0 libspice-server1 libxatracker2
nvidia-libopencl1-331 nvidia-opencl-icd-331 nvidia-prime
The following packages will be upgraded:
nvidia-331 thunderbird thunderbird-gnome-support xserver-xorg-input-evdev
xserver-xorg-input-mouse xserver-xorg-input-synaptics
xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-fbdev
xserver-xorg-video-openchrome xserver-xorg-video-qxl
xserver-xorg-video-savage xserver-xorg-video-sis xserver-xorg-video-vmware
14 upgraded, 8 newly installed, 1 to remove and 742 not upgraded.
217 not fully installed or removed.
Need to get 0 B/82.4 MB of archives.
After this operation, 196 MB disk space will be freed.
Do you want to continue? [Y/n] Y
E: Could not open file descriptor -1
E: Prior errors apply to /var/cache/apt/archives/libxatracker2_10.1.3-0ubuntu0.2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/nvidia-331_331.38-0ubuntu7.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libcuda1-331_331.38-0ubuntu7.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libmessaging-menu0_13.10.1+14.04.20140410-0ubuntu1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/nvidia-libopencl1-331_331.38-0ubuntu7.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/nvidia-opencl-icd-331_331.38-0ubuntu7.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/bbswitch-dkms_0.7-2ubuntu1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/nvidia-prime_0.6.2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/thunderbird_1%3a31.2.0+build2-0ubuntu0.14.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/thunderbird-gnome-support_1%3a31.2.0+build2-0ubuntu0.14.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-input-evdev_1%3a2.8.2-1ubuntu2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-input-mouse_1%3a1.9.0-1build1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-input-synaptics_1.7.4-0ubuntu1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-input-vmmouse_1%3a13.0.0-1build1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-input-wacom_1%3a0.23.0-0ubuntu2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-fbdev_1%3a0.4.4-1build1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-openchrome_1%3a0.3.3-1build1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-qxl_0.1.1-0ubuntu3_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-savage_1%3a2.3.7-2ubuntu2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-sis_1%3a0.10.7-0ubuntu6_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/xserver-xorg-video-vmware_1%3a13.0.2-2ubuntu1_amd64.deb
debconf: apt-extracttemplates failed: No such file or directory
(Reading database ... 790188 files and directories currently installed.)
Removing nvidia-304 (304.116-0ubuntu0.0.1) ...
Removing all DKMS Modules
Error! There are no instances of module: nvidia-304
304.116 located in the DKMS tree.
Done.
update-alternatives: warning: /etc/alternatives/x86_64-linux-gnu_gl_conf is dangling; it will be updated with best choice
update-alternatives: warning: /etc/alternatives/i386-linux-gnu_gl_conf is dangling; it will be updated with best choice
update-alternatives: warning: /etc/alternatives/glamor_conf is dangling; it will be updated with best choice
Traceback (most recent call last):
File "/usr/bin/quirks-handler", line 26, in <module>
import Quirks.quirkapplier
File "/usr/lib/python2.7/dist-packages/Quirks/quirkapplier.py", line 26, in <module>
import XKit.xutils
ImportError: No module named XKit.xutils
dpkg: error processing package nvidia-304 (--remove):

Kenley_Fritts
November 25th, 2014, 02:16 AM
I forgot to mention, that this system was progressively upgraded from 12.04, then to 13.04, then finally to 14.04. I was never able to log into the desktop after 14.04 upgrade, and the nvidia-304 driver seemed to have been the issue, but i'm not certain.

This is a desktop system, there is 1 drive that is split into 2 partitions, it has Windows 7 in the main partition and Ubuntu was installed after freeing up space and shrinking the Windows partition. There is plenty of free space on the disk, and there are plenty of free iNodes.

Kenley_Fritts
December 2nd, 2014, 07:12 PM
I believe the main problem stems from E: Could not open file descriptor -1 and all the problems with /var/cache/apt/archives.

I'm going to try removing the the files in /var/cache/apt/archives and try again.

mrgs
December 2nd, 2014, 07:50 PM
A long chain of upgrades makes the system more and more fragile. Have you considered a fresh install of 14.04 or 14.10?

Kenley_Fritts
December 5th, 2014, 06:30 PM
I can do a re-install, and that would correct it all and be done. This is sort of an experiment and I would like to attempt to repair the problem and that way it might help others who run into this, or similar issue.

I don't consider myself and expert, but am very familiar and have installed/used/upgraded/re-installed all types of Linux systems. Probably, this system is already unrepairable, but just thought I would see who else might have a suggestion or experience.

Kenley_Fritts
December 6th, 2014, 01:54 AM
Update: Found a method to essentially force an upgrade to the 14.04.1 which I'm currently in the process. I'm following the Fixing Forcing Upgrade section - http://www.cyberciti.biz/faq/howto-upgrade-to-ubuntu-14-04-from-ubuntu-13-10-or-12-04/

I keep seeing the following message repeated as the packages are being processed:

Processing triggers for hicolor-icon-theme (0.13-1) ...

(gtk-update-icon-cache-3.0:17445): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
Processing triggers for man-db (2.6.7.1-1) ...


Preparing to unpack .../python-pil_2.6.1-1_amd64.deb ...
Unpacking python-pil:amd64 (2.6.1-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...

(gtk-update-icon-cache-3.0:18061): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
(Reading database ... 795958 files and directories currently installed.)
Removing python-qt3 (3.18.1-5) ...
Processing triggers for python-support (1.0.15) ...
(Reading database ... 795944 files and directories currently installed.)

I'll report back after it's completed.

Kenley_Fritts
December 6th, 2014, 02:08 AM
Correction: The forced upgrade is installing 14.10 from 14.04.1.

Kenley_Fritts
December 6th, 2014, 03:33 AM
The forced upgrade to Utopic 14.10 worked!

From a root ssh prompt, I ran:
do-release-upgrade -d

It took around 45 minutes to complete.
I suspect that the Old Nvidia drivers were causing the problem, I couldn't fix it by resetting or reinstalling the drivers or X. I believe the forced upgrade corrected all this.

mrgs
December 6th, 2014, 04:37 AM
Good, please mark the thread 'solved'.